Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#2112 closed defect (fixed)

Redirect loop of forums

Reported by: Funkatronic Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: Component - Forums Keywords:
Cc:

Description

Found this bug by accident and I've been able to reproduce it on BbPress 2.2.3 and WordPress 3.5. The following creates a redirect loop for the forum it's performed on and causes the forum page to be unavailable:

  1. Create a category
  2. Create a forum
  3. Make the category the parent of the forum
  4. Trash the category without removing the forum as a child
  5. Go to the forum edit page and update it with no parent selected

After doing this the permalink of the forum becomes an infinite redirect loop and you’ll get an error from your server and browser. When you get the error screen, your browser should show the old permalink that includes the category slug, even though the new permalink shouldn't have it. The bad part is that even if you untrash the category and make it the parent of the forum again, the redirect loop stays the same. This also makes the slug of said forum unusable.

I did this by accident and then was able to reproduce using the previously mentioned steps. Just wanted to let you guys know. Can’t find a way to fix this but to prevent it from occurring, make sure you unlink forums from a category BEFORE you want to delete said category.

Change History (7)

#1 @johnjamesjacoby
8 years ago

  • Keywords 2nd-opinion dev-feedback added; needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can't duplicate this in trunk. Closing as worksforme. If anyone can duplicate, go ahead and reopen.

#2 @sandy786
7 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

#3 @sandy786
7 years ago

Yes i have same problem but didn't find any solution for that

#4 in reply to: ↑ description @netweb
7 years ago

  • Keywords 2nd-opinion removed
  • Milestone set to Awaiting Review
  • Priority changed from high to normal
  • Severity changed from major to normal

Replying to Funkatronic:

  1. Create a category
  2. Create a forum
  3. Make the category the parent of the forum
  4. Trash the category without removing the forum as a child
  5. Go to the forum edit page and update it with no parent selected

Following these steps exactly I cannot reproduce the issue.

@sandy786 Can you reproduce the issue using the above steps or a different method?

#5 @johnjamesjacoby
7 years ago

Just tested this exact process again, and also cannot duplicate given these steps.

That said, there are some post hierarchy issues with pages in WordPress core right now, mostly surrounding non-published post statuses. Is it possible the trashed category was private or hidden?

#6 @sandy786
7 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Problem resolve first leave as working state now create duplicate forum/categories with same name > now move them after moving delete duplicate !

it work in many state

thanks

#7 @netweb
7 years ago

  • Keywords dev-feedback removed
  • Milestone Awaiting Review deleted

Thanks for the follow up. Indeed if you don't empty the 'trash' of deleted posts not just in bbPress, but WordPress in general you will have issues surrounding duplicate names/slugs.

Note: See TracTickets for help on using tickets.