Skip to:
Content

#2094 closed defect (fixed)

BuddyPress: 'Forum' tab isn't shown after a new group is created with a forum

Reported by: r-a-y Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.2.2
Component: BuddyPress Keywords: commit
Cc: jmdodd@…

Description

During the group creation process, if you create a group with a forum, the 'Forum' tab does not show up.

I've attached a patch that addresses this.

You could probably change:

$checked = bp_get_new_group_enable_forum() || groups_get_groupmeta( bp_get_current_group_id(), 'forum_id' );

to:

$checked = groups_get_groupmeta( bp_get_current_group_id(), 'forum_id' );

or filter 'bp_get_new_group_enable_forum' to do the group meta 'forum_id' check as well.

Let me know what you think.

Attachments (1)

2094.01.patch (1.0 KB) - added by r-a-y 16 months ago.

Download all attachments as: .zip

Change History (5)

r-a-y16 months ago

comment:1 johnjamesjacoby16 months ago

  • Keywords commit added; has-patch removed
  • Milestone changed from Awaiting Review to 2.3

Confirmed and valid. Patch could be cleaned up by moving the (bool) type cast around, but works as intended.

comment:2 follow-up: jmdodd16 months ago

  • Cc jmdodd@… added

comment:3 in reply to: ↑ 2 jmdodd16 months ago

Disregard; imported forums not being associated with groups looks like a different issue.

comment:4 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4602]) BuddyPress Groups:

  • In maybe_unset_forum_menu(), also check for current groupmeta.
  • Props r-a-y.
  • Fixes #2094.
Note: See TracTickets for help on using tickets.