Skip to:
Content

#2088 closed defect (fixed)

topic text disappears after topic marked as private

Reported by: alexvorn2 Owned by: johnjamesjacoby
Milestone: 2.3 Priority: normal
Severity: normal Version: trunk
Component: Topics Keywords:
Cc: pippin@…

Description

  1. user 2 creates a topic,
  2. admin marks this as private

result

text disappears for for both users

Change History (14)

comment:1 alexvorn217 months ago

  • Component changed from General to Topics
  • Version changed from 2.1 to trunk

comment:2 johnjamesjacoby17 months ago

I don't understand what the problem is here. Details? Expectations?

comment:3 alexvorn217 months ago

  • Summary changed from topic text dispensary after topic marked as private to topic text disappears after topic marked as private

comment:4 alexvorn217 months ago

topic text disappears.

Expectation:

After the topic was marked private, to show topic text (description) for admins and author (user who created the topic)

comment:6 johnjamesjacoby16 months ago

  • Milestone changed from Awaiting Review to 2.3

comment:7 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4564]) Add support for private post statuses in topics and replies loops. Fixes #2088.

comment:8 alexvorn216 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

still an issue...

For admin (keymaster) the text shows but for author of the topic - no!
author of the topic is user2 - subscriber (participant).

In other words a participant should view his private topic.

For example for posts, a private is visible only to author of the post and admins + editors.
A subscriber, contributor or anonymous user can't view the private post, getting a 404 page error.

Last edited 16 months ago by alexvorn2 (previous) (diff)

comment:9 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

How are regular non-moderator non-keymaster users creating private topics on your site? This is not normally allowed in bbPress core.

comment:10 alexvorn216 months ago

You are right!

But, for example:

User2 created the topic (he is participant (subscriber)).

Administrator (key master) after the user2 created the topic - marked the topic 'Private'.

And after that the User2 can't view his own topic that he created. But he should view because he created it.

Solution:

Allow Participant to view his own private topic even if he can't mark it private.

comment:11 alexvorn216 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 johnjamesjacoby16 months ago

  • Owner set to johnjamesjacoby
  • Status changed from reopened to new

That makes sense I suppose, though it will require some extra sorting out.

comment:13 mordauk16 months ago

  • Cc pippin@… added

If this gets added, then I think private replies should get added too. Perhaps following along with the idea behind the [Private Replies extension](http://wordpress.org/extend/plugins/bbpress-private-replies/)?

comment:14 johnjamesjacoby16 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4673]) Rejig the post_status logic in bbp_has_topics() and bbp_has_replies() to use the 'perm' query variable when appropriate. This allows unfamiliar topic and reply statuses to work as intended. Also allows post authors to view their own private content. Fixes #2088.

Note: See TracTickets for help on using tickets.