Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#2077 closed defect (worksforme)

Topics are made sticky when moved to a different forum

Reported by: NickMackz Owned by:
Milestone: 2.2.3 Priority: normal
Severity: normal Version: 2.2.2
Component: Component - Topics Keywords: needs-testing needs-patch 2nd-opinion
Cc: stephen@…, nick.a.mackenzie@…

Description

If I edit a topic and change the forum that it is posted in, it moves correctly but gets set as sticky.

Change History (9)

#1 @johnjamesjacoby
8 years ago

  • Keywords needs-testing needs-patch added

That's weird. Can't duplicate, but it's possible some form field logic is messed up.

#2 @johnjamesjacoby
8 years ago

  • Component changed from General to Topics
  • Keywords 2nd-opinion added
  • Milestone changed from Awaiting Review to 2.2.3

Anyone able to confirm this? I'm not seeing this in trunk?

#3 @netweb
8 years ago

I also cannot replicate this using bbPress /trunk/ and WordPress 3.5-RC3-23080.

Steps tried to repro:

  • Via /wp-admin/edit.php?post_type=topic
  • Select Topic and 'edit'
  • Edit above topic AND move the topic to another parent forum

Relusts: Default as expected bbPress functionality, topic has been edited and is visible in the new forum parent and has no 'sticky' or 'super-sticky' CSS Classes.

#4 @netweb
8 years ago

  • Cc stephen@… added

#5 @johnjamesjacoby
8 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Closing as worksforme. May be worth posting in the support forums until we can find a clear reproduction method.

#6 @aaclayton
8 years ago

I have this exact same problem.

Hopefully we can find the cause. Might have something to do with moving topics from one child forum to another? All of my forums are children of some parent category. Whenever myself or one of my moderators moves a topic, it always gets stickied within its destination forum.

#7 @NickMackz
8 years ago

  • Cc nick.a.mackenzie@… added

This stopped happening on my site for a while and is now happening again. However, I cannot replicate it on a clean version of bbPress and BuddyPress so it must be a theme or plugin conflict.

aaclayton, what theme are you using? I am using Custom Community 1.10.

EDIT: tested with stock Custom Community and works fine. Tested disabling various bbPress related plugins on my site and the problem appears to be with GD bbPress Attachments.

Last edited 8 years ago by NickMackz (previous) (diff)

#8 @aaclayton
8 years ago

Hey, sorry Nick, didn't see your response.

I'm using a custom parent WP/BuddyPress/bbPress theme on http://tamrielfoundry.com

I use a hierarchical forum setup, so every forum lives inside a forum category. When I move a topic (always from one child forum to another child forum, not always within the same parent category) sometimes the thread is stickied in the process. I can't seem to identify a common causal factor for this happening, but the same thing happens on my local test site.

I'm running the following plugins:
bbPress
BuddyPress
W3TC
jQuery Colorbox
Members

I haven't made any huge bbPress hacks that would change the way that topics are moved. The only thing that I can think of which sets my configuration of bbPress apart from what might be considered "stock" is that I use a hierarchical system of forum categories. No topics live in the parent forum, only in the children. Maybe it has something to do with moving threads from one child forum to another when topics are present in the parent. /shrug

It's nothing that breaks my site, but it is a bit annoying to always have sticky threads popping up because I forget to unstick them after they get moved.

#9 @netweb
8 years ago

FYI: In #2157 a new repair tool was added 'Recalculate the sticky relationship of each topic'

Note: See TracTickets for help on using tickets.