Skip to:
Content

bbPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#2071 closed defect (worksforme)

bbPress conflicting with Multisite

Reported by: maineyak Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: Component - Users Keywords: reporter-feedback
Cc:

Description

I had everything set up fine, Until this last update. When a member creates a new blog when bbPress is activated, they are only granted participant status to their blog, so they cannot even access their dashboard. I deactivated all plugins to make sure in fact it was bbPress that was causing this, and it is. When I deactivate bbPress, they can access their dashboard, and are granted Administrator status. I just happened to be testing new accounts today, and realized this was happening. I did just update bbPress to the latest, so I’m assuming it was due to this latest update, as it was working fine before. I posted this on the forum, and was told to submit a ticket.

Change History (8)

#1 @alexvorn2
9 years ago

  • Component changed from General to Users

#2 @alexvorn2
9 years ago

edited

Last edited 9 years ago by alexvorn2 (previous) (diff)

#3 @johnjamesjacoby
9 years ago

Not actually related at all.

#4 @johnjamesjacoby
9 years ago

This is both likely, and complicated. It will require some in-depth testing that I don't currently have time to invest in. Anyone else able to step in and check this out?

Probably related to: http://bbpress.trac.wordpress.org/browser/branches/2.2/includes/core/actions.php#L91

#5 @netweb
9 years ago

WordPress 3.5-RC3-23080 MultiSite install using sub folders and bbPress r4535 'Network Activated'

When creating a new site from /wp-admin/network/site-new.php with bbPress 'Network Activated'

These are the permissions after the site is created logged in as 'admin' via eg. /site7/wp-admin/users.php

Username Site Role Forum Role
admin Participant Participant
site7 Administrator

'admin' above is the 'Network Admin' and 'site7' is the username/sitename for the /site7/ MU site admin

Logging out as 'admin', logging in as 'Site7' can successfully login to /wp-admin/ with full access

Looking at users permissions from the now logged in user 'site7' these have now been updated to:

Username Site Role Forum Role
admin Participant Participant
site7 Administrator Keymaster

There is a bug in WP 3.5-RC3-23080 when a user is signing up and creating the new MU sites themselves, once this bug is fixed I'll update with what permissions are assigned if the user creates the new MU site themself.

#6 @netweb
9 years ago

WordPress RC-4 23108 MultiSite with sub folders and bbPress r4550 'Network Activated'

I am still unable to reproduce this issue using the 'super-admin' above or as the actual a 'user' below.

  • Register as a 'new user' via /wp-signup.php
  • Supply valid Username and email address
  • Check option 'Gimme a site!' click next
  • Supply a valid site name and site title, click sign up
  • Open activation link sent by WordPress eg. /wp-activate.php?key=1234567890abcdef
  • Open new MU site eg. /site11/
  • Ensure you are logged out of the site
  • Login using ther username/password supplied in the activation email
  • Open wp-admin via site URL eg. /site11/wp-admin/

Examine user permissions via eg. /site11/wp-admin/users.php

Username Site Role Forum Role
admin Participant Participant
site7 Administrator Keymaster

Note: 'admin' is the WP Network user with 'super-admin' wp-role.

#7 @johnjamesjacoby
9 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Very awesome. Thanks for doing that. Adding reporter feedback, and closing as worksforme.

Feel free to reopen if anyone can reproduce, and include detailed steps.

#8 @johnjamesjacoby
9 years ago

  • Keywords reporter-feedback added
Note: See TracTickets for help on using tickets.