Skip to:
Content

bbPress.org

Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#2063 closed enhancement (invalid)

bbPress widget title don't show if widget title empty.

Reported by: ellipszist's profile ellipszist Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.2.2
Component: API - Widgets Keywords:
Cc: alexvornoffice@…, wordpress@…

Description

Please set default bbPress widget title if empty show.

(bbPress) Forums List
(bbPress) Login Widget
(bbPress) Recent Replies
(bbPress) Recent Topics
(bbPress) Statistics
(bbPress) Topic Views List

Attachments (4)

widget title empty.PNG (12.2 KB) - added by ellipszist 12 years ago.
don't show widget title.PNG (9.8 KB) - added by ellipszist 12 years ago.
WordPress widget title.PNG (5.9 KB) - added by ellipszist 12 years ago.
WordPress widget title2.PNG (9.9 KB) - added by ellipszist 12 years ago.

Download all attachments as: .zip

Change History (20)

#1 follow-ups: @johnjamesjacoby
12 years ago

  • Resolution set to invalid
  • Status changed from new to closed

This is by design, to allow empty titles if you so choose.

#2 @johnjamesjacoby
12 years ago

  • Milestone 2.3 deleted

#3 in reply to: ↑ 1 @ellipszist
12 years ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

Replying to johnjamesjacoby:

This is by design, to allow empty titles if you so choose.

WordPress if show widget title on site?

see WordPress widget title.PNG

it is title empty on Widgets page.

see WordPress widget title2.PNG

I'm comeback if needed to edit title.

#4 @johnjamesjacoby
12 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

This is not a bug. This is intentional.

#5 @ellipszist
12 years ago

I think it enhancement, as wordpress widget.

Last edited 12 years ago by ellipszist (previous) (diff)

#6 @ellipszist
12 years ago

  • Keywords 2nd-opinion added
  • Resolution invalid deleted
  • Status changed from closed to reopened

I'm don't reopen again if you OK :)
reopen need everyone comment.

Last edited 12 years ago by ellipszist (previous) (diff)

#7 @alexvorn2
12 years ago

  • Cc alexvornoffice@… added
  • Keywords 2nd-opinion removed

I agree that default titles should show.
If a user want to not to display titles of the widgets, he can use widget_title filter.

Last edited 12 years ago by alexvorn2 (previous) (diff)

#8 @alexvorn2
12 years ago

  • Milestone set to Future Release

#9 @alexvorn2
12 years ago

We can use this:

$title = apply_filters( 'widget_title', empty( $instance['title'] ) ? __( 'WIDGET NAME' ) : $instance['title'], $instance, $this->id_base );

#10 in reply to: ↑ 1 ; follow-up: @sooskriszta
11 years ago

Replying to johnjamesjacoby:

This is by design, to allow empty titles if you so choose.

Totally with JJJ on this. I use empty titles a lot so as to show no widget title.

Last edited 11 years ago by sooskriszta (previous) (diff)

#11 in reply to: ↑ 10 @alexvorn2
11 years ago

Replying to sooskriszta:

Replying to johnjamesjacoby:

This is by design, to allow empty titles if you so choose.

Totally with JJJ on this. I use empty titles a lot so as to show no widget title.

If default WordPress widgets show titles then why bbPress widgets should not?

#12 @alexvorn2
11 years ago

Only Custom Menu and Calendar widgets does not show the widget title as default.

#13 @sooskriszta
11 years ago

WordPress widgets do not show titles when the field is left empty.

#14 @MZAWeb
11 years ago

  • Cc wordpress@… added
  • Keywords needs-patch removed
  • Resolution set to invalid
  • Status changed from reopened to closed

Why force the user to write code to filter the default title out? If the user wants it empty, let's leave it empty.

An also "fixing" this now won't be backwards compatible.

#15 @sooskriszta
11 years ago

Hear hear!

#16 @alexvorn2
11 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.