Skip to:
Content

#2014 closed defect (fixed)

Cannot Choose Parent Topic

Reported by: mordauk Owned by:
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.1.2
Component: Back-end Keywords: has-patch
Cc: stephen@…

Description

With latest trunk, it's not possible (in my install at least) to select the parent forum for a topic. The problem might be related to 1901.

The parent forum cannot be selected when creating new topics nor when editing.

I haven't had a chance to look into the problem further yet. See the attached screenshot.

Attachments (5)

Screen Shot 2012-11-08 at 11.20.03 AM.png (43.8 KB) - added by mordauk 18 months ago.
Ajax Parent Lookup.png (10.2 KB) - added by netweb 18 months ago.
Ajax Parent Lookup2.png (15.4 KB) - added by netweb 18 months ago.
metaboxes.diff (1.4 KB) - added by netweb 18 months ago.
metabox.patch (1.4 KB) - added by mordauk 18 months ago.
Localizes help text

Download all attachments as: .zip

Change History (25)

comment:1 johnjamesjacoby18 months ago

Works for me. Will need more information to be helpful.

comment:2 mordauk18 months ago

Can you attach a screenshot of how it should look?

netweb18 months ago

comment:3 follow-up: netweb18 months ago

This threw me at first also and I think we need some help text around this area.

It is an 'ajax' lookup, start typing the forum name for the forum parent, forum name for the topic or topic name for the reply.

Screenshot attached...

comment:4 netweb18 months ago

  • Cc stephen@… added

comment:5 in reply to: ↑ 3 mordauk18 months ago

Replying to netweb:

This threw me at first also and I think we need some help text around this area.

It is an 'ajax' lookup, start typing the forum name for the forum parent, forum name for the topic or topic name for the reply.

Screenshot attached...

Ohhh . . . yeah that is definitely not intuitive. I would never have assumed that to work that way. It works perfectly. I imagine a simple "Begin Typing Parent Name" text below or similar would be just fine.

netweb18 months ago

netweb18 months ago

comment:6 netweb18 months ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 2.2

I'm not sure if using a <br> to add the line is in the WP Admin style guides for the diff... ;)

Screen reader text also?

@@ -299,6 +299,7 @@ function bbp_forum_metabox() {
        <strong class="label"><?php _e( 'Parent:', 'bbpress' ); ?></strong>
        <label class="screen-reader-text" for="parent_id"><?php _e( 'Forum Parent', 'bbpress' ); ?></label>
        <input name="parent_id" id="bbp_forum_id" type="text" value="<?php echo esc_attr( $post_parent ); ?>" />
+       <br><i>(Begin Typing Parent Name to populate list)</i>
    </p>
 

mordauk18 months ago

Localizes help text

comment:7 johnjamesjacoby18 months ago

I don't like the idea of adding more UI here. Would rather we fix the experience. Thoughts?

comment:8 mordauk18 months ago

I really don't like the extra UI either. What about using something like Select2?

comment:9 follow-up: johnjamesjacoby18 months ago

Don't want to pull in a new library; suggest should be fine. Just need to dial in the experience.

comment:10 in reply to: ↑ 9 mordauk18 months ago

Replying to johnjamesjacoby:

Don't want to pull in a new library; suggest should be fine. Just need to dial in the experience.

Sure. I think the most important element here is giving the user an immediate idea of how to select the parent. Perhaps open the suggest box on :focus?

comment:11 follow-up: johnjamesjacoby18 months ago

Notes from Jane:

If i saw the text box, even with "enter the name of the forum you want this topic to be in' or some such, i'd think a lot of people would wind up typing a new forum name.

Recall really doesn't work for a lot of people even with autosuggest, especially people with dyslexia and other language disabilities, so there's an accessibility hit by not having the list be an option too.

I agree. I'm inclined to switch it back to the drop-down for 2.2, and revisit this more in 2.3; maybe with a simpler and more appropriate UI that isn't a kludge from existing WordPress core functionality.

comment:12 in reply to: ↑ 11 mordauk18 months ago

Replying to johnjamesjacoby:

Notes from Jane:

If i saw the text box, even with "enter the name of the forum you want this topic to be in' or some such, i'd think a lot of people would wind up typing a new forum name.

Recall really doesn't work for a lot of people even with autosuggest, especially people with dyslexia and other language disabilities, so there's an accessibility hit by not having the list be an option too.

I agree. I'm inclined to switch it back to the drop-down for 2.2, and revisit this more in 2.3; maybe with a simpler and more appropriate UI that isn't a kludge from existing WordPress core functionality.

I'm inclined to agree with that. Perhaps building something similar to the Add Link (for existing content) could be built. When the user clicks "set parent", a modal would be opened that displays all of the forums. This way they could scroll through the list, instead of seeing them all in a select menu. This would also allow us to load a small number at a time and load more via ajax as the user scrolls through the list.

comment:13 netweb18 months ago

Yep... Agreed...

comment:14 johnjamesjacoby17 months ago

  • Milestone changed from 2.2 to 2.3

Punting. Revert incoming.

comment:15 johnjamesjacoby17 months ago

(In [4414]) Forums Admin:

  • Revert usage of Suggest for choosing a forum parent via auto-complete.
  • Revert parts of r4260 and r4261.
  • See #1910, #2014.

comment:16 netweb17 months ago

Currently unable to assign a forum to a category (forum parent) via 'Forum Attributes -> Parent'

Assigning a forum ( or a forum category) to a parent forum works as intended.

(I'm not sure if this is from the reverts above or was happening before the reverts)

comment:17 netweb17 months ago

Workaround:

  • Edit the 'parent' forum properties from 'category' to 'forum'
  • Assign any sub-forums to the 'parent forum'
  • Change the 'parent forum' properties back from 'forum' to 'category'

comment:18 johnjamesjacoby17 months ago

To clarify the above:

  • Forum categories are disabled in the dropdown.

Fixing.

comment:19 johnjamesjacoby17 months ago

  • Milestone changed from 2.3 to 2.2

comment:20 johnjamesjacoby17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r4438, with some restrictions in place for topics and replies.

Note: See TracTickets for help on using tickets.