Skip to:
Content

Opened 18 months ago

Closed 18 months ago

Last modified 18 months ago

#2002 closed defect (worksforme)

User roll settings does not allow group to see hidden/private forums

Reported by: anointed Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Users Keywords:
Cc:

Description (last modified by johnjamesjacoby)

I used the members plugin by Justin to create a new role 'forum moderator' and for that role I applied the following permissions

See: https://dl.dropbox.com/u/2045194/bbpress/moderator-role.png

The important part is I assigned the ability to see hidden and private forums to the user group.

I then changed all of my members who were moderators on my old system to moderators on the new system.

Problem:
I create a forum and choose either private or hidden. The problem is my forum moderators, when they go to that forum, get a page not found.

Strange part, is if they go through the admin they are able to see the posts in the hidden/private forum just fine and can even reply to them.

In fact if they know the url to a topic that is in a private/hidden forum then they can see it just fine in their browser, and can reply.

It is only when they try to go directly to the private/hidden forum that they get the page not found error.

*If I change the forum permission back to standard, then they can see the forum just fine.

As the site admin I can see the forum just fine.

Overall:
There seems to be no permission setup where I can create either a private or hidden forum and allow any group to access them.

Maybe there is a permission checkbox that I missed above?

Change History (3)

comment:1 anointed18 months ago

hmmm, can I suggest that you add a css rule to this site img { max-width: 100%; } seems like my image is blowing out of the container.

comment:2 johnjamesjacoby18 months ago

  • Component changed from General to Users
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Going to close this as worksforme. The new sub-roles system in trunk should negate the need for you creating your own roles. That said, if you're making custom roles and applying custom caps, you'll need to experiment with exactly what capabilities work and what don't, and identify any specific bugs as you go.

Roles and caps have very much been in flux since the beginning, and what's in trunk now is going to be the approach going forward.

comment:3 johnjamesjacoby18 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.