Skip to:
Content

#1996 closed defect (fixed)

HTML validation

Reported by: alexvorn2 Owned by:
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.1.2
Component: Code Improvements Keywords:
Cc:

Description

After I checked for HTML5 validation some errors show up.

1: Duplicate ID
In a topic page the id of the page is the same as the first reply id, classes too Related - http://bbpress.trac.wordpress.org/ticket/1980

2: Bad value for attribute action on element form: Must be non-empty
In a forms: form-forum.php, form-reply.php, etc...

3: Attribute maxlength not allowed on element input at this point
in the line with this: <input type="hidden" name="bbp_reply_title" id="bbp_reply_title" value="Reply To: topic 2" maxlength="" />

Change History (4)

comment:1 johnjamesjacoby18 months ago

(In [4277]) Reply Titles:

  • Attribute 'maxlength' not allowed on hidden fields.
  • See #1996.

comment:2 johnjamesjacoby18 months ago

(In [4278]) Form Actions:

  • Use the_permalink() as a form action in forum/topic/reply forms.
  • See #1996.

comment:3 johnjamesjacoby18 months ago

  • Milestone changed from Awaiting Review to 2.2

comment:4 johnjamesjacoby18 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Remaining issue is a duplicate of #1980; marking as resolved.

Note: See TracTickets for help on using tickets.