Skip to:
Content

#1994 closed defect (fixed)

Forum index conflict with old BuddyPress forums

Reported by: anointed Owned by:
Milestone: 2.2 Priority: normal
Severity: normal Version: 2.1
Component: BuddyPress Keywords:
Cc: jmdodd@…

Description

My setup is running bbPress 2.2trunk (svn nightly cron job) with buddyPress 1.7trunk (svn nightly cron job) and WordPress 3.5beta2.

Everything was working perfectly yesterday, well other than the converter doesn't work for replies, but other than that, I had everything setup absolutely perfect. I made ZERO changes to anything on my end. The only thing that changed was the bbpress/buddypress svn update from today.

PROBLEM:

I had it setup where I had both bbPress forums and buddypress group forums on my primary site. This was NOT using the old bbPress 1x, everything was setup for 2x.

The way I did this was during the install of buddypress, I did NOT check the box to add forums. I simply installed bbPress as normal.

On the bbPress admin page is the option to allow buddypress to have group forums and I created a forum 'group-forums' and assigned them to buddypress.

This meant when I created a new buddypress group forum they showed up as:

group-forums/group-forum-x/
group-forums/group-forum-y/

This gave me a link: http://anointed.net/forums/forum/group-forums/

When I would go to that link I could see all the group forums below just like normal.

I was also able to have further 'top level' forums via bbpress that had nothing to do with buddypress.

Now when I visit that url, I get the error:

 PHP Fatal error:  Call to undefined function bp_directory_forums_search_form() in /home/mysite.net/public_html/wp-content/plugins/buddypress/bp-themes/bp-default/forums/index.php on line 29, referer: http://mysite.net/forums/forum/group-forums/

Something broke, and now I can't see the normal bbPress forums index page at all.

I don't know which of the updates today broke everything, but something did. This is a HUGE step backwards somehow.

In the meantime, I am running svn for bbPress on my server, and I don't understand it all that well. Is there a command I can type to 'backtrack' a few vs. of bbPress so I can find the one that works?

Attachments (1)

1994.diff (732 bytes) - added by jmdodd 18 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 johnjamesjacoby18 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Not nearly enough info here to be helpful. Can't call it a HUGE step if you have no idea what happened.

"Group forums" are intended to live within BuddyPress Groups, not within the forums themselves. The way these two pieces of software work are in development, and are going to go through phases of instability while we iterate on them.

I imagine the fatal errors are from theme compat catching a file it wasn't previously catching. Sounds like a specific side effect of a bigger issue.

Anyhow, closing this since it's not really helpful.

comment:2 anointed18 months ago

Here's what I did.

I deactivated buddypress and all buddypress plugins, now I am able to see my bbPress forums just fine.

http://anointed.net/forums/forum/group-forums/

I reactivate the buddypress default theme and now I get the 500 error when I go to the forum homepage.

That is what I am trying to say, the link above worked perfectly the day before yesterday. I had no problems.

Then something changed, either in bbPress or buddyPress itself, as I made no other changes, and now I get 500 errors.

I hope this is more clear.

comment:3 anointed18 months ago

The way I had it, group forums indeed did show up and 'live within' the groups. So when I went to a buddypress group page, I could see the group forum just fine.

However:
I could ALSO see the group forums and child group forums just fine in the normal bbPress forum template.

I had the best of both worlds and it was perfect.

comment:4 anointed18 months ago

Ok I reverted all the way back to 4253

link to 'group forums' in the nice bbPress format
http://anointed.net/forums/forum/group-forums/

link to the standard bbPress forum
http://anointed.net/forums/

link to a group forum
http://anointed.net/groups/website-support/forums/

See how everything works perfectly?

That is what I mean when I say whatever changed, is a HUGE step backwards. I went from a perfectly functioning site, other than I could not edit the topics/replies that belonged to groups, to a 500 error situation where the site was totally unusable.

I hope now I have provided enough information. if you need more let me know.

comment:5 anointed18 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:6 follow-up: anointed18 months ago

OK, this has to help, I went through all the changes, one at a time, uploading them one by one. It turns out the changeset that broke everything is older than I thought.

http://bbpress.trac.wordpress.org/changeset/4264

that is the change that broke my site and caused the 500 errors.

I am safe staying on 4263, but something in 4264 is not happy.

comment:7 jmdodd18 months ago

  • Cc jmdodd@… added
  • Component changed from General to BuddyPress

I duplicated this error on a clean install with WP nightly from 10/26/2012, bbPress r4270, BuddyPress r6469.

Plugins active: BuddyPress, bbPress, using default options for all.

When BuddyPress's "Site-wide and Group forums allow for focused, bulletin-board style conversations. Powered by bbPress." is not checked, this error occurs on example.com/forums because a BuddyPress forums template is being used, even though bbPress should be handling the display via theme compat.

When the BuddyPress "Site-wide and Group forums" option is checked, with bbPress active, the page displays the following when New Topic is clicked:

You are not a member of any groups so you don't have any group forums you can post in. To start posting, first find a group that matches the topic subject you'd like to start. If this group does not exist, why not create a new group? Once you have joined or created the group you can post your topic in that group's forum.

This seems to indicate that the BuddyPress group forums are taking over the /forums location before bbPress gets a chance to use it for the site-wide forums.

comment:8 in reply to: ↑ 6 johnjamesjacoby18 months ago

  • Milestone set to 2.2

Replying to anointed:

OK, this has to help, I went through all the changes, one at a time, uploading them one by one.

If you used Subversion like we've been talking about for years, a 1 line command would switch your checkouts for you automatically. Seriously, we need to get you using this correctly if you're going to do this level of debugging (which is awesome.)

It turns out the changeset that broke everything is older than I thought.

http://bbpress.trac.wordpress.org/changeset/4264

Sweet. This is perfect.

that is the change that broke my site and caused the 500 errors.

I am safe staying on 4263, but something in 4264 is not happy.

jmdodd is going to look into it.

comment:9 johnjamesjacoby18 months ago

  • Milestone changed from 2.3 to 2.2
  • Summary changed from something changed today and broke everything to Forum index conflict with old BuddyPress forums

Renamed to something less panicky and more helpful. See #1669.

comment:10 jmdodd18 months ago

Undesired behavior: When the BuddyPress default theme is active, bbp_get_theme_compat_templates cycles through:

[30-Oct-2012 19:31:27] bbpress/plugin-bbpress.php
[30-Oct-2012 19:31:27] bbpress/bbpress.php
[30-Oct-2012 19:31:27] bbpress/forums.php
[30-Oct-2012 19:31:27] bbpress/forum.php
[30-Oct-2012 19:31:27] bbpress/generic.php
[30-Oct-2012 19:31:27] bbpress/page.php
[30-Oct-2012 19:31:27] bbpress/single.php
[30-Oct-2012 19:31:27] bbpress/index.php
[30-Oct-2012 19:31:27] forums/plugin-bbpress.php
[30-Oct-2012 19:31:27] forums/bbpress.php
[30-Oct-2012 19:31:27] forums/forums.php
[30-Oct-2012 19:31:27] forums/forum.php
[30-Oct-2012 19:31:27] forums/generic.php
[30-Oct-2012 19:31:27] forums/page.php
[30-Oct-2012 19:31:27] forums/single.php
[30-Oct-2012 19:31:27] forums/index.php

and ends up using /wp-content/plugins/buddypress/bp-themes/bp-default/forums/index.php, producing the above-mentioned errors and confusion between group forums templates.

When Twenty Twelve theme is active (no custom forums templates, etc. as are included in the BuddyPress default theme), it cycles through:

[30-Oct-2012 19:34:21] bbpress/plugin-bbpress.php
[30-Oct-2012 19:34:21] bbpress/bbpress.php
[30-Oct-2012 19:34:21] bbpress/forums.php
[30-Oct-2012 19:34:21] bbpress/forum.php
[30-Oct-2012 19:34:21] bbpress/generic.php
[30-Oct-2012 19:34:21] bbpress/page.php
[30-Oct-2012 19:34:21] bbpress/single.php
[30-Oct-2012 19:34:21] bbpress/index.php
[30-Oct-2012 19:34:21] forums/plugin-bbpress.php
[30-Oct-2012 19:34:21] forums/bbpress.php
[30-Oct-2012 19:34:21] forums/forums.php
[30-Oct-2012 19:34:21] forums/forum.php
[30-Oct-2012 19:34:21] forums/generic.php
[30-Oct-2012 19:34:21] forums/page.php
[30-Oct-2012 19:34:21] forums/single.php
[30-Oct-2012 19:34:21] forums/index.php
[30-Oct-2012 19:34:21] plugin-bbpress.php
[30-Oct-2012 19:34:21] bbpress.php
[30-Oct-2012 19:34:21] forums.php
[30-Oct-2012 19:34:21] forum.php
[30-Oct-2012 19:34:21] generic.php
[30-Oct-2012 19:34:21] page.php

and uses /wp-content/themes/twentytwelve/page.php, triggering theme_compat.

comment:11 johnjamesjacoby18 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4283]) Template Locations:

  • Revert part of r4264.
  • Fix regression where bbPress was pulling in files from unexpected locations.
  • Fixes #1994.

comment:12 jmdodd18 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Problem still exists; bbp_locate_template was added in r4264. Confirmed on a clean install with r4283.

jmdodd18 months ago

comment:13 johnjamesjacoby18 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in r4284.

Note: See TracTickets for help on using tickets.