Skip to:
Content

bbPress.org

Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#1956 closed enhancement (duplicate)

Context-sensitive search

Reported by: sooskriszta Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Component - Search Keywords:
Cc: jared@…, stephen@…

Description

If there is one thing that sucks in bbPress, it is search.

Oh, search works fine if you want to do a global, WordPress search.

But it falls flat when forum-users want to run a:

  1. Global forums search.
  2. Context-sensitive search:

2.1. Searching within a specific forum or subforum.
2.2. Searching within a specific thread (topic and its replies)
2.3. Searching within "my posts"

For end-users, it can pretty frustrating sometimes.

Like phpBB and pretty much any bb software out there, bbPress would do well to pull up its socks in this one area.

Change History (7)

#1 @jaredatch
9 years ago

  • Cc jared@… added
  • Priority changed from high to normal
  • Severity changed from major to normal

I agree, it could be improved. Namely with some sort of prepackaged/themed search results template.

Best I have encountered is Matt Brett's template on MakeupGeek.com. However even that doesn't have the ability to narrow by forums.

http://www.makeupgeek.com/?post_type=reply&s=test

This could definitely have potential for 2.3 IMO. Just will be interesting on how the best way to logistically go about it, without screwing with the existing search template.

Maybe the first pass should just be something like what Makeup Geek does. Even though it doesn't have a lot of bells and whistles, it's still better than whats in place now.

#2 @netweb
9 years ago

  • Cc stephen@… added

#3 @johnjamesjacoby
9 years ago

  • Milestone changed from Awaiting Review to Future Release

Putting in future release, and I'd be surprised if there wasn't a ticket about this already.

bbPress shouldn't be responsible for fixing WordPress's search functionality. bbPress is purposely missing most UI in this regard, because there's no great way to integrate results into WordPress's global search output.

#4 @sooskriszta
9 years ago

For reference, check out what phpBB does: http://forum.opencart.com/viewforum.php?f=20

The Search link on top right (next to FAQ, register, Login) is Global forums search...in our case, it could be WordPress Search which we might leave untouched.

Slide your eyes down the left, however, and under the forum title you'll find a Search box (next to the big fat New Topic button). This is their context-sensitive search. If I at a forum page, this box searches within the forum. If I at "View My Posts" it searches within my posts (topics and replies). If I am at a thread's page, it searches within that thread (topic and replies)...etc...

#5 @johnjamesjacoby
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1575, which will be addressed in 2.3.

#6 @johnjamesjacoby
8 years ago

  • Milestone Future Release deleted

#7 @sooskriszta
8 years ago

Not identical to #1575 but I guess it would depend on how you action that one off. Will wait for 2.3 with bated breath to see what's coming.

Note: See TracTickets for help on using tickets.