Skip to:
Content

bbPress.org

Opened 8 years ago

Closed 8 years ago

#1927 closed defect (worksforme)

Pagination broken for bbp-single-topic shortcode in a post

Reported by: ddean Owned by:
Milestone: 2.2 Priority: high
Severity: normal Version: 2.1.2
Component: General Keywords: has-patch
Cc: alexvornoffice@…, stephen@…

Description

Steps to reproduce:

  1. Enable permalinks (anything besides Default)
  2. Create a blog post containing a "[bbp-single-topic id=xx]" shortcode
  3. Exceed 15 topic posts and try pagination links

Attachments (1)

bbpress-paging-patch.diff (618 bytes) - added by ddean 8 years ago.
Patch against plugin branch

Download all attachments as: .zip

Change History (11)

#1 @alexvorn2
8 years ago

posts have their own pagination and it can be in a conflict with the pagination in the "[bbp-single-topic id=xx]" shortcode. the second pagination link should redirect to the forum list - "page 2"...

#2 @alexvorn2
8 years ago

  • Cc alexvornoffice@… added

#3 @johnjamesjacoby
8 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 2.1.3
  • Priority changed from normal to high

Lame. This used to work. Unsure what's preventing it, but it needs to be fixed.

#4 @netweb
8 years ago

  • Cc stephen@… added

#5 follow-up: @netweb
8 years ago

REF: http://bbpress.org/forums/topic/pagination-doesnt-work-properly-bbpress-wordpress-plugin/

I am pretty sure another case with bbp-single-topic.php (correct me if I am wrong) is that the above reference is the same behavior when bbPress & BuddyPress are installed and viewing a single topic.

Behavior in that example:

  • Single Topic /groups/morb/forums/topic/umvm-mudbd-npm-6/
  • Current Page 2 Link: /groups/page/2/
  • Page 2 Link Should Be: groups/morb/forums/topic/umvm-mudbd-npm-6/page/2

#6 in reply to: ↑ 5 @johnjamesjacoby
8 years ago

Replying to netweb:

I am pretty sure another case with bbp-single-topic.php (correct me if I am wrong) is that the above reference is the same behavior when bbPress & BuddyPress are installed and viewing a single topic.

Agree; there's a huge chance these are related.

@ddean
8 years ago

Patch against plugin branch

#7 @ddean
8 years ago

  • Keywords has-patch added; needs-patch removed

This patch limits use of fancy pagination to static pages and the "topic" post type.

#8 @johnjamesjacoby
8 years ago

  • Milestone changed from 2.1.3 to 2.2

This is fixed for me in the plugin branch, though I'm not sure what I did exactly to fix it. Moving to 2.2 since it will happen before 2.1.3.

#9 @netweb
8 years ago

Works for me also?

Anyone else still seeing this running /trunk? Otherwise I think this can be closed.

#10 @netweb
8 years ago

  • Milestone changed from 2.3 to 2.2
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.