Skip to:
Content

#1906 closed defect (fixed)

Group forum topics: Edit and Merge don't work with Buddypress installed

Reported by: kraigg Owned by:
Milestone: 2.2 Priority: high
Severity: major Version: 2.1
Component: Topics Keywords: has-patch dev-feedback
Cc: jmdodd@…

Description

Edit and Merge links in group forum topics don't work when Buddypress is also installed.

When I click the 'edit' link of a forum topic, it takes me to the group forum page with the message "Oh bother! No forums found". Underneath the message is the 'Create new topic' form (and not the edit form, as it should do).

bbPress 2.1 on its own works fine, but once paired with Buddypress, it has these problems.

I disabled the forum component in the Buddypress settings, and ticked the 'Allow BuddyPress Groups to have their own forums' in the bbPress settings.

Thanks for looking into this, really appreciate it! :)

Plugins installed:
WordPress 3.4.1, bbPress 2.1, Buddypress 1.6 (also tried with Buddypress 1.5.6, with the same results)

Attachments (2)

1906.diff (22.6 KB) - added by jmdodd 18 months ago.
First pass; proposed fix for 1-5 of user-facing group forum.
1906.2.diff (24.7 KB) - added by johnjamesjacoby 18 months ago.
Streamline some logic in original patch

Download all attachments as: .zip

Change History (9)

comment:1 johnjamesjacoby21 months ago

  • Milestone changed from Awaiting Review to 2.2

Moving to 2.2 to look more into BuddyPress compat.

comment:2 kraigg21 months ago

Thanks John, appreciate it.

In the meantime, is there a hardcoded link I can add to make the Edit link work?

I notice that the Edit link doesn't seem to be any ID or reference to the reply. For example: http://www.mywebsite.com/groups/mygroup/forums/topic/reply-to-mytopic/edit/

Whereas the Trash link (which works) has the following URL
http://www.mywebsite.com/groups/mygroup/forums/topic/mytopic/?action=bbp_toggle_reply_trash&sub_action=trash&reply_id=444&_wpnonce=08bcd8bb3a

Could this be the problem? Is there some hard code I could add to the group forum template to make it work?

comment:3 anointed19 months ago

My ticket got closed as a duplicate so I wanted to move my topic over as a reply here so it doesn't get lost in the mix.

Running trunk as of today on WordPress 3.5beta1 bbPress 2x, buddypress 1.7

When I try to edit a group topic or reply nothing happens.

It's easiest to explain via a video: http://www.youtube.com/watch?v=xZ___b7gQGU&feature=plcp

comment:4 jmdodd19 months ago

  • Cc jmdodd@… added

comment:5 jmdodd18 months ago

Group forums (bbPress plugin, not BuddyPress's version):

  1. topic edit and merge do not work
    • clicking on edit or merge reloads the topic again
  2. reply edit and split do not work
    • clicking on edit gives the "no topics found here" message
    • clicking on split shows the topic again
  3. paging through a list of topics in a forum does not work (pagination links)
  4. paging through replies to a topic does not work (pagination links)
  5. individual topic pagination on forum view does not work
  6. topic favorite and subscribe take you to the Groups directory (absence of topic.js causes AJAX to fail)
  7. group forum admin-only
    • can't edit a group's forum
    • can't add multiple forums to a group -- intended behavior?
    • text-only (not live) forum row and topic row actions

jmdodd18 months ago

First pass; proposed fix for 1-5 of user-facing group forum.

comment:6 jmdodd18 months ago

  • Keywords has-patch dev-feedback added

johnjamesjacoby18 months ago

Streamline some logic in original patch

comment:7 johnjamesjacoby18 months ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [4266]) BuddyPress:

  • Remove advanced group forum admin UI; go with feature parity of existing bbPress 1.1 installations for a v1.
  • Remove support for multiple forums/groups combinations. Assume the first item in the array is the only one.
  • Adds some canonical redirection to group forum content.
  • Maps forum content links to group forums when needed.
  • Add support for editing of topics and replies within group forums.
  • Some more to do here, but closing in on completeness.
  • Huge props jmdodd,
  • Fixes #1906.
  • See #1669.
Note: See TracTickets for help on using tickets.