Skip to:
Content

bbPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1785 closed defect (bug) (duplicate)

After editing a reply, topic's tags changed

Reported by: hinok Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Component - Topic Tags Keywords:
Cc:

Description

Scenario:
I created new topic.
I added replies from another account.
While editing last reply, I changed reply's tag.
Save.

What's happened?
Topic's tags changed, after changing reply.
Topic was not created on that account, only last reply.

I think that, topic's tags and reply's tags should be diffrent.
Otherwise, it does not make sense to allow add or edit tags to reply.

Attachments (1)

1785.diff (549 bytes) - added by jaredatch 10 years ago.

Download all attachments as: .zip

Change History (10)

#1 follow-up: @alexvorn2
10 years ago

the another user should be able only to add a new tag, not to replace the main tag of the post if it is not a member moderator or administrator... I think so.

#2 @jaredatch
10 years ago

  • Keywords needs-testing removed

Was able to duplicate the issue, looking into the cause.

@jaredatch
10 years ago

#3 @jaredatch
10 years ago

  • Keywords has-patch 2nd-opinion needs-testing added; needs-patch removed

From what I can tell this fixes things, but I'm not certain that's all there is to it - is there supposed to be multiple topic-tag taxonomies? (just doesn't seem right on first glance)

Eg: http://sht.tl/KGxQ

#4 in reply to: ↑ 1 @johnjamesjacoby
10 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to alexvorn2:

the another user should be able only to add a new tag, not to replace the main tag of the post if it is not a member moderator or administrator... I think so.

This is currently by design, until a more robust tagging UI can be built.

Replying to jaredatch:

From what I can tell this fixes things, but I'm not certain that's all there is to it - is there supposed to be multiple topic-tag taxonomies? (just doesn't seem right on first glance)

Eg: http://sht.tl/KGxQ

This is normal.

Closing as a duplicate of #1546.

#5 @johnjamesjacoby
10 years ago

  • Keywords has-patch 2nd-opinion needs-testing removed
  • Milestone 2.1 deleted
  • Priority changed from high to normal
  • Severity changed from major to normal

#6 @jaredatch
10 years ago

  • Keywords dev-feedback added
  • Milestone set to Awaiting Review
  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Version 2.0 deleted

Part of it was I rarely use tags so I mis-understood how things were stored, however I think I figured out the issue which was throwing me off. See if this makes more sense.

In 2.0.x when you are on the 'reply form' for a topic, the Tags field is pre-filled with the tags - this makes sense.

If the OP tagged the thread "tag1" and "tag2" the person replying already has those tags in the Tag Field, so they can simply add on any additional tags, eg "tag3". Easy peezy.

In 2.1 this doesn't auto populate (in my 2 test setups).

If the OP tagged the thread "tag1" and "tag2", the person replying gets served an empty tag field. Not knowing they need to re-input the current tags (tag1/tag2) they will probably just enter in "tag3" - on the assumption it will get appended to the current list of tags. This results in the tags getting screwed up - losing "tag1" and "tag2" completely.

Am I missing something or is this a bug? :)

Last edited 10 years ago by jaredatch (previous) (diff)

#7 @johnjamesjacoby
10 years ago

  • Keywords dev-feedback removed
  • Resolution set to duplicate
  • Status changed from reopened to closed

New bug, new ticket. :) For what it's worth, what you're describing works fine for me.

#8 @jaredatch
10 years ago

No problem. More information in #1791.

#9 @johnjamesjacoby
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.