Skip to:
Content

bbPress.org

Opened 10 years ago

Closed 10 years ago

#1633 closed defect (bug) (wontfix)

Featured Images

Reported by: marv51 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Component - Forums Keywords: has-patch
Cc:

Description

When creating a forum in the dashboard. You can set a featured image in the picture upload box. This is not shown anywhere in the UI and can also not be undone. This breaks themes that use this kind of images.

Attachments (3)

patch.diff (309 bytes) - added by marv51 10 years ago.
Patch that adds the featured image meta box
patch.2.diff (309 bytes) - added by marv51 10 years ago.
Patch that adds the featured image meta box
Screenshot.PNG (100.6 KB) - added by marv51 10 years ago.
Here is a screenshot showing the problem (circled red).

Download all attachments as: .zip

Change History (7)

@marv51
10 years ago

Patch that adds the featured image meta box

@marv51
10 years ago

Patch that adds the featured image meta box

#1 @marv51
10 years ago

  • Keywords has-patch added

Sry uploaded twice. This adds the 'thumbnail' capability to the forums post type. This fixed my problem and is quite a nice feature actually.

Please be gentle, this is my first patch ever.

Last edited 10 years ago by marv51 (previous) (diff)

#2 @johnjamesjacoby
10 years ago

  • Milestone changed from Awaiting Review to 2.1

Congrats on your first patch! Yay! :)

So I don't quite understand the problem. :) bbPress has these built-in features turned off so that plugins or themes can choose to optionally turn them on if they support them. Post thumbnails are not enabled by bbPress, and there is no danger of data being lost breaking things, etc...

#3 @marv51
10 years ago

Your are describing the way it should be, but nevertheless that's not how I see it here in my test install. I can very clearly see the link "Set as featured Image" after I upload a image in the editor for the forum. As you said, that is not the expected behavior.
I will try with a clean install later and post a screenshot.

@marv51
10 years ago

Here is a screenshot showing the problem (circled red).

#4 @johnjamesjacoby
10 years ago

  • Milestone 2.1 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Appears you found a WordPress bug!

I created WordPress ticket #WP18669 for you, and am closing this one since it's not something we can fix here.

If you want to enable featured images for your forums, I'd suggest making a small plugin to filter 'bbp_register_forum_post_type' instead. That way your changes won't get wiped out when updates to bbPress roll in.

Thanks for the report and good work!

Note: See TracTickets for help on using tickets.