Skip to:
Content

Opened 6 years ago

Closed 4 years ago

#1596 closed defect (worksforme)

Theme bbPress (Twenty Ten) 1.2 not activated

Reported by: pavelevap Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0
Component: Appearance - Theme Compatibility Keywords:
Cc: pavelevap@…, pavelevap, aesqe, stephen@…, georgemamadashvili@…

Description

After activating plugin, theme bbPress (Twenty Ten) 1.2 is available in WordPress Themes section. But theme screenshot is not found and after activating theme there is error message: "The active theme is broken. Reverting to the default theme."

Bellow theme is following description:

The template files are located in /themes/twentyten. The stylesheet files are located in C:\WWW\Wordpress\wp-content\plugins\bbpress/bbp-themes/bbp-twentyten.

Maybe there is problem with absolute (for stylesheet) and relative (for other template files) paths?

Change History (15)

#1 @johnjamesjacoby
6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

More likely this is a problem with a local Windows install and using a local folder path. I remember Mark McWilliams running into a similar issue about a year ago.

This should be a non issue with a properly configured WAMP/IIS setup. If the issue persists, the resides in the WordPress core function 'plugin_dir_path'

Closing as workforme.

#2 @johnjamesjacoby
6 years ago

  • Milestone changed from Awaiting Review to 2.0
  • Version 2.0 deleted

#3 @pavelevap
6 years ago

  • Cc pavelevap added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have used many other plugins (and child themes) on my install and there was never similar problem.

This strange behaviour started only some months ago. Everything worked well when I tested bbPress plugin before. So, I tried to search the cause of this change and it is changeset number 3329 (http://bbpress.trac.wordpress.org/changeset/3329). Until 3328 everything worked well. And now, after changing $this->themes_dir for latest changeset, everything also works well. I suppose, that it is some kind of bug, so I reopened this ticket...

#4 @GautamGupta
6 years ago

  • Version set to 2.0

[2650] (#1358) was reversed in [3329] by mistake. :)

#5 @GautamGupta
6 years ago

Maybe we could add a little comment there, so that it is not reversed again. :)

#6 @johnjamesjacoby
6 years ago

The reason this problem manifests itself in bbPress is it's using the core WP API's and does not discriminate against being in either plugin folder (plugins or mu-plugins.) A greater portion of plugins never need to reference their own path, and the ones that do have a tendency to make assumptions about where they are located.

See #WP18501 for WordPress Core patch to fix the root cause.

r3329 breaks bbPress when installed in /mu-plugins, so I'm inclined to use a bundled version of the patch attached to #WP18501 if we need to.

#7 @johnjamesjacoby
6 years ago

  • Version 2.0 deleted

#8 @johnjamesjacoby
6 years ago

  • Milestone changed from 2.0 to 2.1

Since this can be tied directly to a potential WP core bug with registering theme directories, I'm of the opinion we shouldn't commit to our own work-around for only a short while before the next WP release. We can also fix this as we go if the impact is larger than anticipated.

Moving to 2.1 milestone to judge the impact of this on the 2.0 release.

#9 @johnjamesjacoby
6 years ago

  • Milestone 2.1 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed
  • Version set to 2.0

3 months and no impact or changes. Closing this as worksforme.

#10 @desbest
5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

#11 follow-up: @aesqe
5 years ago

  • Cc aesqe added

why not just leave

$this->themes_dir = WP_PLUGIN_DIR . '/' . basename( dirname( __FILE__ ) ) . '/bbp-themes';

until WP team fixes register_theme_directory()?

#12 in reply to: ↑ 11 @johnjamesjacoby
5 years ago

Replying to aesqe:

why not just leave

$this->themes_dir = WP_PLUGIN_DIR . '/' . basename( dirname( __FILE__ ) ) . '/bbp-themes';

until WP team fixes register_theme_directory()?

Because then bbPress will not work when in the /mu-plugins directory.

#13 @netweb
5 years ago

  • Cc stephen@… added

#14 @Mamaduka
5 years ago

  • Cc georgemamadashvili@… added

#15 @netweb
4 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Closing, worksforme

Note: See TracTickets for help on using tickets.