Skip to:
Content

bbPress.org

Opened 11 years ago

Closed 10 years ago

#1585 closed defect (bug) (wontfix)

P2 and bbPress incompatibility

Reported by: kahless Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Appearance - Theme Compatibility Keywords: needs-patch needs-testing
Cc:

Description

Odd bug with P2 and bbPress (in theme compatibility mode). Create a page to serve as the homepage and a page to serve as the blog page. Enable bbPress and create some forums, topics, and replies. Modify your settings to use your homepage as the static page and your blog page as the blog page. Visit the homepage and make sure the title is correct. Now add the bbPress Reply List widget to the sidebar and visit the homepage and note the title is one of the forums and not the title of your homepage post. You get the same behavior if you add the Topic List widget. Not sure what the issue is.

Change History (2)

#1 @johnjamesjacoby
10 years ago

  • Milestone changed from Awaiting Review to 2.1
  • Version 2.0 deleted

There are a number of issues with bbPress and P2 which come from bbPress wiping out the main $post global and forcing comments off without P2 understanding why.

That said, I cannot reproduce the issue you mention. The widget title, the page title, and the title attributes of each widget item appear correct from my testing. Any more information you can provide (links, etc...) would be awesome.

#2 @johnjamesjacoby
10 years ago

  • Milestone 2.1 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Going to close this for now citing general incompatibilities between P2 and bbPress 2.

Note: See TracTickets for help on using tickets.