Skip to:
Content

bbPress.org

Opened 10 years ago

Closed 10 years ago

#1567 closed defect (bug) (fixed)

[bbp-topic-index] does not function properly at certain circumstances

Reported by: funnycat777 Owned by:
Milestone: 2.0 Priority: normal
Severity: minor Version: 2.0
Component: Appearance - Theme Compatibility Keywords:
Cc:

Description

I am currently using bbpress 2.0 beta 3b.
When I create a page on wordpress, and use the shortcode [bbp-topic-index], bbpress topics show properly in my page. However, if I set that particular page as a front page, [bbp-topic-index] does not work properly.
For example, I am currently setting "Topics Per Page" to 10, so 10 topics show in page 1. Therefore it will show as "Showing topics 1 to 10." When I click on page 2, it should show topics 11-20, but it keeps saying, "Showing topics 1 to 10". I would like to be able to show topics 11 - 20, and so on.

Change History (8)

#1 @cnorris23
10 years ago

  • Component changed from Front-end to Theme Compatability
  • Keywords [bbp-topic-index] removed
  • Milestone changed from Awaiting Review to 2.0

Semi-confirmed. To elaborate, when a page is set as the front page and you add the [bbp-topic-index] shortcode, the pagination links appear to work. However, they work, because they're actually linking as example.com/topics/page/2/, instead of the expected example.com/page/2/. If you manually visit example.com/page/2/ under this scenario, you get the results outlined by funnycat777, ie. - only the first 10 topics are shown.

#2 @johnjamesjacoby
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3354]) Adjust the check-order of pagination permalinks in bbp_has_topics(), allowing shortcode usage pagination to work. Fixes #1567.

#3 follow-up: @funnycat777
10 years ago

  • Resolution fixed deleted
  • Severity changed from normal to minor
  • Status changed from closed to reopened

When I set a page as a front page and add [bbp-topic-index] shortcode, the pagination links appear (1 2 ... 4 →, it says). When I place my mouse on top of page 2, the link shows as "example.com/page/2/", not "example.com/topics/page/2/", so I cannot replicate your scenario. How do you change the settings of pagination link to target "example.com/topics/page/2/"?.

Also, can you let me know which version of bbpress will reflect the fix?

#4 in reply to: ↑ 3 @johnjamesjacoby
10 years ago

Replying to funnycat777:

Also, can you let me know which version of bbpress will reflect the fix?

RC1 will have the fix in it.

#5 @johnjamesjacoby
10 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Also, please only reopen this ticket if you can reproduce this as broken in the development version.

#6 @funnycat777
10 years ago

Ok, I will try it on RC1 when it comes out. Will let you know if it is still happening.

#7 @cnorris23
10 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I can confirm that this is only partially fixed. The pagination links are fixed, but no matter what page you're on, it still only shows the first ten. Spent some time on it last night, but I've yet to track down the problem. This only happens when the page is set as a static front page.

#8 @johnjamesjacoby
10 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [3361]) Fix pagination issues when using topics shortcode on front page. Also use pagination_base instead of 'page'.

Fixes #1567, #1573. Props scribu.

Note: See TracTickets for help on using tickets.