Skip to:

Opened 5 years ago

Closed 5 years ago

#1399 closed defect (fixed)

subscriptions, emails not sent

Reported by: elfin Owned by:
Milestone: 2.0 Priority: normal
Severity: normal Version:
Component: Front-end Keywords: has-patch tested


In bbp_notify_subscribers the following appears to always match, causing the subscriptions to not run: (@ line 910)

if ( $reply->post_type != $bbp->reply_id || empty( $reply->post_parent ) )
		return false;

post_type will never equal reply_id! But I'm not sure what should be matched there.

Attachments (1)

1399.diff (2.0 KB) - added by GautamGupta 5 years ago.

Download all attachments as: .zip

Change History (6)

#1 @GautamGupta
5 years ago

As you can see here and here, $reply->post_type is actually $bbp->reply_id. But still, subscriptions aren't working for me too.. they did work when I had originally submitted the patch.

#2 @elfin
5 years ago

Before submitting this I printed out the variables - the post_type was still a, erm, post type. Should it not be using $defaults rather than $reply?

5 years ago

#3 @GautamGupta
5 years ago

For this, we can either compact the values on bbp_new_reply hook or just accept $reply_id in bbp_notify_users(). I've attached a patch with the latter method.

#4 @GautamGupta
5 years ago

  • Keywords has-patch tested added

#5 @johnjamesjacoby
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2711]) Fixes #1399 props GautamGupta

Note: See TracTickets for help on using tickets.