Skip to:
Content

Opened 3 years ago

Closed 3 years ago

#1357 closed defect (fixed)

admin menu disappeared

Reported by: elfin Owned by:
Milestone: 2.0 Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Cc:

Description

Can't find calls to add_menu_page or add_submenu_page at all.

Change History (7)

comment:1 johnjamesjacoby3 years ago

It doesn't use either of them. Deactivate and reactivate bbPress and report back.

comment:2 follow-up: elfin3 years ago

Still no menu, can you tell me what you do use so I can try and track down what is causing it?

comment:3 in reply to: ↑ 2 markmcwilliams3 years ago

Replying to elfin:

Still no menu, can you tell me what you do use so I can try and track down what is causing it?

The Forums, Topics, and Replies are Custom Post Types. So the handling of them, and the registering of the menu items is dealt with the CPT API, although they show up great at my end, not had anything disappearing here!

comment:4 elfin3 years ago

ahh in that case I know what the issue is likely to be - but will take some investigation to narrow down where it lies.

Last edited 3 years ago by elfin (previous) (diff)

comment:5 elfin3 years ago

(deleted ref to a.n.other ticket - not related at all)

Can someone confirm where and how the activation function within the bbPress class is actually being called. The caps aren't being setup correctly on my install and I can only think that this is the issue.

Once the caps are added the menu items then appear...

comment:6 elfin3 years ago

and similarly deactivation doesn't call the deactivate routine - which is why it's still working for some people and not others.

comment:7 johnjamesjacoby3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2604]) Fixes #1357 by rearranging the activation and deactivation procedures.

Note: See TracTickets for help on using tickets.