Skip to:
Content

bbPress.org

Opened 14 years ago

Closed 14 years ago

#1273 closed defect (bug) (fixed)

Dashboard CSS issues

Reported by: mr_pelle's profile mr_pelle Owned by:
Milestone: 1.0.3 Priority: low
Severity: minor Version: 1.1-alpha
Component: General - Administration Keywords: css has-patch tested
Cc:

Description

In bb-admin/style.css there are some little displaying problems:

Line 1055 reads:

table.widefat tr td { width: 18%; }

This wrecks tables first column at Posts and Topics sections of the Dashboard


Line 1658 reads:

form.settings div.table { width: 300px; }

This de-aligns table background from its content (v1.0.2 also has this).

Attachments (6)

1273.diff (464 bytes) - added by mr_pelle 14 years ago.
basic patch
1273.2.diff (336 bytes) - added by mr_pelle 14 years ago.
before-patch.png (18.8 KB) - added by mr_pelle 14 years ago.
after-patch.png (18.7 KB) - added by mr_pelle 14 years ago.
1273-final.diff (334 bytes) - added by mr_pelle 14 years ago.
Simple patch to fix table displaying
1273.final.final.diff (336 bytes) - added by chrishajer 14 years ago.
fixed width table patch for bb-admin/style.css

Download all attachments as: .zip

Change History (18)

@mr_pelle
14 years ago

basic patch

#1 @mr_pelle
14 years ago

I've attached a simple patch that fixes the problems. I noted that form.settings div.table width must be at least 32%.

#2 @mr_pelle
14 years ago

  • Keywords has-patch tested added

SVN repository tells me I'm forbidden to submit the patch: can anyone do this, please?
You may close the ticket after that.

#3 @GautamGupta
14 years ago

Which browser are you using? Seems fine to me. Please post screenshots.

#4 @mr_pelle
14 years ago

I'm sorry, regarding the second issue (table background) I forgot to specify which table I was referring to. It's AUTH_KEY &co. table, in "Wordpress Integration" admin submenu.

I've locally re-installed the trunk release and the first issue seems to be ok now. I'll re-attach a better patch in minutes.

I'm using FF 3.6 on Mac, anyway.

@mr_pelle
14 years ago

#5 @mr_pelle
14 years ago

This fixes just AUTH_KEY &co. table in "Wordpress Integration" admin submenu.

#6 @mr_pelle
14 years ago

Probably the other issue was caused by the CSS of some plugin I had on...

#7 @mr_pelle
14 years ago

Can anyone upload attachment:1273.2.diff, so that we can close this ticket, please?

@mr_pelle
14 years ago

#8 @chrishajer
14 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2434]) bb-admin CSS fixes. Fixes #1273. Props mr_pelle

#9 @mr_pelle
14 years ago

  • Keywords has-patch tested removed
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from enhancement to defect

Reopen this because AUTH_KEY &co. table in "Wordpress Integration" admin submenu still gets displayed badly. I've set table width to 40% and it seems enough to fix it.

@mr_pelle
14 years ago

Simple patch to fix table displaying

#10 @mr_pelle
14 years ago

  • Keywords has-patch tested added

This final patch should fix it once for all.

#11 @chrishajer
14 years ago

This is sometimes fixed and sometimes broken based on the size of the browser viewport. I would recommend this be set to a minimum width since we know the content that will always be displayed inside the table. No need for a table that resizes based on width. I will submit a patch.

@chrishajer
14 years ago

fixed width table patch for bb-admin/style.css

#12 @chrishajer
14 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [2447]) Fixed width table for WordPress keys in bb-admin. Fixes #1273. Props mr_pelle

Note: See TracTickets for help on using tickets.