Skip to:
Content

bbPress.org

Opened 10 years ago

Closed 10 years ago

#1272 closed defect (fixed)

Log Out from admin causes parse_url warning error

Reported by: jlevandowski Owned by:
Milestone: 1.0.3 Priority: normal
Severity: normal Version: 1.1-alpha
Component: Back-end Keywords: has-patch, needs-testing
Cc:

Description

After logging in the the admin dashboard. If you click the Log Out Link you get the following error.

Warning: parse_url(/bb-login.php?action=logout&redirect_to=http://example.com/) [function.parse-url]: Unable to parse URL in /home/public_html/forums/bb-includes/functions.bb-core.php  on line 627

Attachments (1)

admin-header.diff (604 bytes) - added by jlevandowski 10 years ago.

Download all attachments as: .zip

Change History (6)

#1 @GautamGupta
10 years ago

  • Component changed from Administration to Back-end
  • Milestone set to 1.0.3
  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce - neither on sub-domain nor on sub-directory install.

#2 @jlevandowski
10 years ago

Maybe it's a cookie setting issue. I have it intergrated with wordpress 3.0-beta2

#3 @jlevandowski
10 years ago

Not sure why in logged-in.php the logout link is created by

<?php bb_logout_link(); ?>

where in admin-header.php it is

<?php bb_logout_link( array( 'redirect' => bb_get_uri( null, null, BB_URI_CONTEXT_HEADER ) ) ); ?>

#4 @jlevandowski
10 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Changing

<?php bb_logout_link( array( 'redirect' => bb_get_uri( null, null, BB_URI_CONTEXT_HEADER ) ) ); ?>

to

to<?php bb_logout_link( array( 'redirect' => urlencode( bb_get_uri( null, null, BB_URI_CONTEXT_HEADER) ) ) ); ?>

in admin-header.php fixes this issue.

#5 @jlevandowski
10 years ago

  • Keywords has-patch needs-testing added
  • Resolution set to fixed
  • Status changed from reopened to closed

Patch submitted.

Note: See TracTickets for help on using tickets.