Skip to:
Content

Opened 4 years ago

Closed 4 years ago

#1209 closed defect (duplicate)

rss.php errors

Reported by: Nightgunner5 Owned by: chrishajer
Milestone: 1.0.3 Priority: high
Severity: major Version: 1.0.2
Component: Front-end Keywords:
Cc:

Description

Posted by soundgnome:

Hey there, just had an issue with the "favorites" RSS and wanted to share my solution in case anyone else was having the same problem. Maybe it was just a Firefox thing, but the favorites URL (e.g., rss.php?profile=1) was interpreted as "unformatted XML"--there was an error message and the entire markup was displayed. I eventually discovered this was caused by an <a> tag inside the channel's <link> tag. By changing the "bb_get_profile_link" call to a "get_user_profile_link" call in rss.php I got the URL without the tag, and the feed was interpreted correctly.


Incidentally, I also noticed a couple other things about the script that seemed a bit off--


1) There are a number of calls to "die()" if the feed turns out to be empty--seems like either an empty feed or an error page would be preferable to this silent failure.


2) The "bb_send_304()" call doesn't take into account that the feed itself may have changed recently, e.g. threads added to a "favorites" list won't show up until activity on one of the threads causes the feed to be refreshed. (Which is not totally illogical, but it can be confusing for the user to add a favorite, refresh the feed, and still not see the newly-added thread.)


I thought about working up a patch to address these issues, but decided to post this first--maybe the script's working exactly as intended and I'm just not understanding it correctly.

Attachments (1)

rss.php.diff (657 bytes) - added by Gautam Gupta 4 years ago.

Download all attachments as: .zip

Change History (6)

Gautam Gupta4 years ago

comment:1 Gautam Gupta4 years ago

  • Milestone set to 1.0.3

I think this is same as #1179 and can get fixed with same type of patch. Attached the diff file.

comment:2 Gautam Gupta4 years ago

  • Keywords has-patch added

comment:3 chrishajer4 years ago

  • Owner set to chrishajer
  • Status changed from new to assigned

comment:4 GautamGupta4 years ago

  • Keywords has-patch removed
  • Version changed from 1.0.1 to 1.0.2

After your have fixed #1181, I will post the correct patch for this (sorry as I had not read the full post).

comment:5 GautamGupta4 years ago

  • Resolution set to duplicate
  • Status changed from assigned to closed

Merging feed tickets into one ticket: #1261

Note: See TracTickets for help on using tickets.