Skip to:
Content

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#1164 closed defect (fixed)

Square brackets added to "topic-move" form unnecessarily

Reported by: chrishajer Owned by:
Milestone: 1.0.3 Priority: low
Severity: minor Version: 1.0.2
Component: Administration Keywords:
Cc:

Description

Would have tagged this 1.0.2 but that version does not exist yet.

Not sure how to describe this one. Occurs in a 1.0.2 upgrade of mine and at bbpress.org since it is using 1.0.2.

When logged in as moderator or someone who can move a topic, you see some weirdness with the "topic-move" form. It looks like brackets were added to the form, as they already exist for Delete, Close and Sticky, but when they are wrapped around the 'move topic' form, it makes the page look weird.

Will attach 1.0.2 and 1.0.1 screenshots. It was fine in 1.0.1 and is broken in 1.0.2. Looks like the addition of $before and $after is fouling it up, for that form anyway.

Attachments (3)

1.0.1.png (5.6 KB) - added by chrishajer 5 years ago.
no brackets here, looks fine, 1.0.1
1.0.2.png (5.7 KB) - added by chrishajer 5 years ago.
unnecessary brackets in 1.0.2, looks bad
[resolved] [resolved] Iindian s-w companies growing « bbPress Support Forums.png (127.8 KB) - added by chrishajer 5 years ago.
just for completeness, here is 1.0.2 at bbpress.org showing badness (using a local theme for display) - thought it was due to the spammer content at first

Download all attachments as: .zip

Change History (12)

chrishajer5 years ago

no brackets here, looks fine, 1.0.1

chrishajer5 years ago

unnecessary brackets in 1.0.2, looks bad

chrishajer5 years ago

just for completeness, here is 1.0.2 at bbpress.org showing badness (using a local theme for display) - thought it was due to the spammer content at first

comment:1 sambauers5 years ago

  • Milestone set to 1.0.3

comment:2 sambauers5 years ago

I'm not going to take away the brackets, but I should update the default theme to display that move form inline with the other controls.

comment:3 timskii5 years ago

If I've read the code correctly, topic_move_dropdown() can accept before and after arguments, which can presumably be set to to remove the square brackets. But it is a tad annoying to suddenly find an existing template visually broken by a minor release.

comment:4 chrishajer5 years ago

If you put the form dropdown on the same horizontal line with the rest, it will be fine. Then the brackets will make sense. Right now they're just silly.

comment:5 sambauers5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [2349]) Better looking move topic form. Fixes #1164.

comment:6 chrishajer4 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Can anyone confirm that this issue still exists in trunk? At bbpress.org we are using 1.1-alpha which should have this fix, and the problem still exists. And I just upgraded another installation from 1.0.2 to trunk r2417 and the issue is still there as well. I'm not sure what was fixed but it still looks terrible to me.

comment:7 GautamGupta4 years ago

  • Keywords 1.0.2 removed
  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 1.0.1 to 1.0.2

This was fixed in the kakumei template, and I guess that the bbpress.org template has not been updated yet. You may open up a new ticket with bbpress.org 2.0 milestone for this issue, but I think it would have been fixed in the new theme by Sam.

comment:8 sambauers4 years ago

Line 650 of the Kakumei stylesheet inlines that form.

http://trac.bbpress.org/browser/trunk/bb-templates/kakumei/style.css#L650

That's the fix on Kakumei, but on bbPress.org that probably won't do enough as there is all that other styling on the form element.

comment:9 chrishajer4 years ago

I was using a custom template as well so I didn't see the fix. When I switched to kakumei, it's correct, so I need to fix my theme.

Note: See TracTickets for help on using tickets.