Skip to:

Opened 7 years ago

Closed 7 years ago

#1059 closed defect (fixed)

backport MBCS fix for PHP 4 into bbPress 0.9 branch

Reported by: _ck_ Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Back-end Keywords: MBCS


In the next security/performance release of 0.9 the MBCS fix that was applied to 1.0 should be backported to 0.9

I believe the problem was in function htmlspecialchars_decode but there may be others.

This will help international users who need MBCS and don't always have access to servers with PHP 5.

I firmly believe PHP 4 should be supported until PHP 5.3 is widely available on many mainstream services.

Change History (2)

comment:1 @sambauers7 years ago

(In [2047]) Copy compat functions from BackPress, See #1059

comment:2 @sambauers7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Those changes are in the 0.9 branch. We should release an update to 0.9 soon to cover this.

Note: See TracTickets for help on using tickets.