Skip to:
Content

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1036 closed defect (fixed)

Installation error creating initial topic on Windows servers

Reported by: williamsba1 Owned by: sambauers
Milestone: 1.0 Priority: high
Severity: major Version: 1.0-rc-2
Component: Installation/Upgrade Keywords:
Cc:

Description

On final step of install error message is displayed. Verified this bug still exists in alpha 6:

DB Error in bb_insert_topic: Incorrect integer value: for column 'topic_id' at row 1

INSERT INTO bb_topics (topic_id,topic_title,topic_slug,topic_poster,topic_poster_name,topic_last_poster,topic_last_poster_name,topic_start_time,topic_time,topic_open,forum_id) VALUES (,'Your first topic','your-first-topic','1','admin','1','admin','2008-12-16 05:10:50','2008-12-16 05:10:50','1','1')

This problem has been around since the previous 1.0 alpha releases. The installation would say that it was successful but it would not create a topic as that error in the last stage would indicate.

The first forum is created and it says there is 1 post but upon clicking said forum it presents you with a "New Topic in this Forum" form. When you post a new topic, it gives you an error: "This topic has been closed."

Details pulled from this forum post: http://bbpress.org/forums/topic/installing-bbpress-10-alpha-4

Change History (6)

comment:1 sambauers5 years ago

  • Milestone set to 1.0-beta
  • Owner set to sambauers
  • Status changed from new to assigned
  • Version set to 1.0-beta (trunk)

Confirmed, looking for solution now.

comment:2 sambauers5 years ago

  • Component changed from Administration to Installation/Upgrade
  • Priority changed from normal to high
  • Severity changed from normal to major

comment:3 sambauers5 years ago

(In [2014]) Don't pass the topic_id to topic insert/update queries or post_id to post insert/update queries. See #1036

comment:4 sambauers5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

That worked. Fixed

comment:5 anonymous5 years ago

  • Milestone 1.0-beta deleted

Milestone 1.0-beta deleted

comment:6 sambauers5 years ago

  • Milestone set to 1.0
Note: See TracTickets for help on using tickets.