Skip to:
Content

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1001 closed defect (worksforme)

PHP 5 and Internel server error

Reported by: wiseacre Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.0-rc-2
Component: Installation/Upgrade Keywords:
Cc:

Description

I can't use bbpress with PHP 5. The result is "500 Internal Server Error"

Change History (8)

comment:1 sambauers5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Works for me. Are you using Windows and IIS?

comment:2 sambauers5 years ago

  • Milestone 1.0-beta & XML-RPC deleted

comment:3 wiseacre5 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Gentoo and Apache

comment:4 _ck_5 years ago

  • Component changed from Administration to Installation/Upgrade
  • Priority changed from high to normal

You need to share many more details, are you getting the error on install, or when you try to load the front page? Or a forum page? Or a topic?

If you are using permalinks, turn them off and see what happens.

See if you can get to the admin menu if it's installed by going to
http://your-domain-name.com/forums/bb-admin/

This kind of question might be more suitable to the bbpress.org forums since it seems to be so specific to you.

comment:5 wiseacre5 years ago

On my hostin PHP 4 is "by default". I am using .htaccess with

AddType application/x-httpd-php5 .php

in my top directory.

With this .htaccess file bbpress does not working at all - I can't install it and can't use it after install.

Installation process is "windows like" - I
1 delete .htaccess
2 create manually bb-config.php,
3 open the start page blog.example.com
4 click "Next" and fill just minimum set of fields. I don't integrate bbpress with my blog.
5 Everything is fine.

Without my .htaccess file bbpres works after install. After upload .htaccess - don't. I cant open anything, can't login and don't have any access. The error message is the same "500 Internal Server Error".

I don't use permalinks or any plugins. Just default state ...

comment:6 sambauers5 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

The problem is with your .htaccess file being misconfigured.

Your host simply may not support PHP5 or they may not allow that Apache directive. You need to contact your host.

comment:7 wiseacre5 years ago

I create .htacces using my hosting company FAQ. It's working with phpmyadmin, SMF, wordpress and every other software ...

comment:8 sambauers5 years ago

Just for completeness linking to the resolution here:

http://bbpress.org/forums/topic/php-5-and-500-internal-server-error

Note: See TracTickets for help on using tickets.