Skip to:
Content

Opened 5 weeks ago

Closed 5 weeks ago

#3240 closed defect (informative)

404 error if forum cacpabilities initially not existing

Reported by: wpturk Owned by:
Milestone: Priority: high
Severity: major Version: trunk
Component: General Keywords:
Cc:

Description

I am running the latest 2.6 RC7 and discovered problem regarding user roles.

I have a two wordpress installations: Say: WP1 (blog) & WP2 (bbpress) which works SSO (single sign on - both installations uses the same user tables)

The users register in WP1. After registration, if a user calls Forum url (WP2), user gets 404 error for thr the first call.

This happens because these 2 entries are missing in wp_usermeta tables:

... | forum_capabilities | a:1:{s:15:"bbp_participant";b:1;}

... | forum_user_level | 0

Second time calling the Forum URL it works because these entries are added at the first call to WP2 (404)

Please, check this. If you need any help, let me know.

Adnan

Change History (3)

#1 @johnjamesjacoby
5 weeks ago

Hi there. If I understand correctly, this might be by design. Roles from one site do not get mirrored to any second site automatically.

Forum roles should be automatically mapped based on the Site role, but it’s plausible there’s an order-of-operations issue happening here, where bbPress hasn’t set the role ahead of the end of your first SSO call, or the user object variable hasn’t been reinitialized.

On the SSO call, does a site role (like Subscriber) get added to the second site? If so, is it possible for you to help backtrace the action hooks that are triggered?

#2 @wpturk
5 weeks ago

Hi, thanks for your reply. I think, this is a special case.

For WP roles, I use "WP-Orphanage Extended" plugin which works well.

For bbpress roles: I solved my Problem hooking to registration process by adding bbpress role to the usermeta table. (during registration)

Thank you.

Adnan


#3 @wpturk
5 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to informative
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.