Skip to:
Content

Opened 13 months ago

Closed 12 months ago

Last modified 2 months ago

#3189 closed defect (fixed)

Topic Title Maximum Length bypass using Inspect Element Tool

Reported by: davelr1 Owned by: johnjamesjacoby
Milestone: 2.6 Priority: high
Severity: normal Version: 2.5.14
Component: Component - Topics Keywords: good-first-bug needs-patch
Cc:

Description

Are you using either the latest version of bbPress, or the latest development version? If not, please update first.

  • Both. The bug works with all versions including the 2.6-beta.

What steps should be taken to consistently reproduce the problem?

  • Basically anyone can create a huge topic title by just using the browser inspect element tool to bypass the char limit.

Does the problem occur even when you deactivate all plugins and use the default theme?

  • Yes.

In case it's relevant to the ticket, what is the expected output or result?

  • Expect to truncate the titles.

What did you see instead?

  • Virtually no char limit for topic titles.

Bug reported here:
https://bbpress.org/forums/topic/topic-title-maximum-length-and-inspect-element-tool/

Change History (3)

#1 @johnjamesjacoby
13 months ago

  • Component changed from General to Component - Topics
  • Keywords good-first-bug needs-patch added
  • Milestone changed from Awaiting Review to 2.6
  • Priority changed from normal to high

#2 @johnjamesjacoby
12 months ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 6784:

Titles: error if forum/topic/reply title is too long.

This change introduces bbp_is_title_too_long() and adds error messages to related forms if titles are too long.

Fixes #3189.

#3 @johnjamesjacoby
2 months ago

In 6881:

Titles: add comment about 8bit mode usage of mb_strlen() to provide extra context.

(After looking at this again, I wasn't confident it was correct. It seems to be, given how it's being used.)

See #3189.

Note: See TracTickets for help on using tickets.