Skip to:
Content

#3140 closed defect (fixed)

Pagination and links to replies are broken on long topics

Reported by: welshdemon Owned by: johnjamesjacoby
Milestone: 2.5.14 Priority: normal
Severity: normal Version: 2.5.13
Component: Component - Replies Keywords: needs-testing
Cc:

Description

Just to confirm this issue exists for me on latest releases of
Wordpress 4.8.1
BBpress 2.5.13

This is exactly the same as this [https://bbpress.org/forums/topic/links-to-last-post-are-wrong-pagination-issue

On a long topic (75 pages), links to the most recent reply are missing the page number and take a user to the start of the topic.

The most recent *working* reply has this URL:
/topic/the-last-person-to-post-in-this-thread-wins/page/76/#post-78004

The next reply from where things break is
/topic/the-last-person-to-post-in-this-thread-wins/#post-79048

clicking on the most recent reply takes user to start of topic, still showing the URL listed above in the address bar.

Also I notice on the same page of replies, One url has /75/ in it.
/topic/the-last-person-to-post-in-this-thread-wins/page/75/#post-77989
-
The reply below has /76/ in the URL.
/topic/the-last-person-to-post-in-this-thread-wins/page/76/#post-78004
-
Then after this the most recent reply has no page number whatsoever.
/topic/the-last-person-to-post-in-this-thread-wins/#post-79048

Running some of the forum repair tools can help remedy this and all reply links can be correct, but add another reply and it breaks again.

This happens with Twenty Sixteen as well as other themes.

Change History (5)

#1 @SergeyBiryukov
19 months ago

  • Component changed from General to Component - Replies

#2 @johnjamesjacoby
19 months ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 2.5.14

This sounds like a duplicate of something we've fixed already.

#4 @johnjamesjacoby
18 months ago

  • Owner set to johnjamesjacoby

See r6643 for the change in trunk that addressed this for 2.6.

I'll port it to 2.5 here, for 2.5.14.

#5 @johnjamesjacoby
18 months ago

  • Resolution set to fixed
  • Status changed from new to closed

In 6685:

Query: use NOT IN strategy in bbp_get_all_child_ids()

This ensures that only specific post-statuses are explicitly excluded from "all child IDs" type queries, where previously post-statuses needed to be specifically defined.

See #3128. Fixes #3140. 2.5 branch, for 2.5.14.

Note: See TracTickets for help on using tickets.