Skip to:
Content

#3135 closed defect (duplicate)

Spamming, trashing, or unapproving a hidden reply should not change reply counts

Reported by: SergeyBiryukov Owned by: johnjamesjacoby
Milestone: Priority: high
Severity: major Version:
Component: API - Moderation Keywords:
Cc:

Description

  1. Create a topic with 1 pending reply.
  2. Topic replies count shows: 0 replies (+1 hidden).
  3. Spam or Trash that reply without approving.
  4. Topic replies count shows: 0 replies (+2 hidden).

Same issue applies to forum replies count and forum topics count, I guess.

Caused by blindly updating the counts via includes/core/actions.php, without checking if the reply already has a non-public status.

Change History (4)

#1 @netweb
19 months ago

  • Keywords needs-patch needs-unit-tests good-first-bug added
  • Milestone changed from Awaiting Review to Future Release

#2 @johnjamesjacoby
19 months ago

  • Milestone changed from Future Release to 2.6
  • Owner set to johnjamesjacoby
  • Priority changed from normal to high
  • Severity changed from normal to major

This is a regression with the bump functions in 2.6, so let’s address this ASAP.

This ticket was mentioned in Slack in #bbpress by jjj. View the logs.


19 months ago

#4 @johnjamesjacoby
19 months ago

  • Keywords needs-patch needs-unit-tests good-first-bug removed
  • Milestone 2.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Let's close this as a duplicate of #3132.

See also: #1799.

Note: See TracTickets for help on using tickets.