Skip to:
Content

#3132 closed defect (duplicate)

Topic reply counts are not updated if the reply status changes on editing

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Component - Replies Keywords:
Cc:

Description

Background: #meta1971 / [meta5686].

Triggered the incorrect replies counts issue recently a couple of times:

  1. Reply to a topic that had no replies, it has 1 reply now.
  2. Edit your reply to fix a typo or something.
  3. Akismet didn't flag the initial post, but flags the edited one for some reason, without updating the replies count.
  4. Once you unspam the post, the topic has 2 replies (+ -1 hidden).

Negative counts are no longer an issue since [6302], however not updating the counts on status changes still is.

The issue is that a plugin like Akismet (or wporg-bbp-user-moderation on w.org/support) can change the reply status via bbp_edit_reply_pre_insert filter, but the status change is not reflected in topic's normal or hidden reply counts.

Change History (2)

This ticket was mentioned in Slack in #bbpress by jjj. View the logs.


19 months ago

#2 @johnjamesjacoby
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#1799 is directly related to this.

The bump functions are hooked into the incorrect actions for their current intended purpose. These will really need to be addressed before 2.6 ships, since they're causing new issues with less simple status transitions.

Let's close this one and move #1799 up to 2.6. It has a patch (that needs refreshing, but is still pretty good.)

Note: See TracTickets for help on using tickets.