Skip to:
Content

bbPress.org

Opened 2 years ago

Closed 2 years ago

#3130 closed defect (fixed)

'bbp_get_forum', 'bbp_get_topic', 'bbp_get_reply' filters never run

Reported by: SergeyBiryukov Owned by: johnjamesjacoby
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: API - Actions/Filters Keywords:
Cc:

Description

[2787] and [2788] introduced bbp_get_forum, bbp_get_topic, and bbp_get_reply filters for the respective functions.

However these filters never run, as each function in question returns the result before the final line gets control. See bbp_get_reply() for example.

Change History (2)

#1 @johnjamesjacoby
2 years ago

  • Milestone changed from Awaiting Review to 2.6

Confirmed. I am a dummy.

These should assign a to variable, and return that through the filters.

#2 @johnjamesjacoby
2 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 6627:

General: Make sure object _get_ functions reach intended filters.

This retains existing behavior of bailing early and returning null if there is a post_type mismatch. Other similar functions would pass the null value through to the filter. These may do that eventually, but let's get these filters working first.

Fixes #3130.

Note: See TracTickets for help on using tickets.