Skip to:
Content

bbPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3127 closed defect (fixed)

Switch Travis CI environment to Trusty - PHP 5.2 & 5.3 no longer available Sept 2017

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Tools - Build Keywords:
Cc:

Description (last modified by netweb)

Via #WP41292

Travis CI have announced they are going to switch to Trusty as the default distro come July 18th 2017

https://blog.travis-ci.com/2017-07-11-trusty-as-default-linux-is-coming

Incoming patch will allow us to continue having PHP 5.2 & 5.3 Travis CI jobs until September 2017


The current availability of PHP 5.2 & 5.3 in the Travis CI build environment is the following:

  1. dist: precise with sudo: false
  2. dist: trusty with sudo: false
  3. dist: precise with sudo: false
  4. dist: precise with sudo: required

bbPress' current Travis CI config uses option 1 above
Travis CI will override this configuration with option 2 come July 18th 2017
We can work around this issue for PHP 5.2 & 5.3 until September 2017 using option 3 for the PHP 5.2 & 5.3 Travis CI job
Come September 2017 Travis CI will overwrite option 3 above with option 4

I've created the following Travis CI issue on the subject: https://github.com/travis-ci/travis-ci/issues/8072

Attachments (1)

3127.diff (531 bytes) - added by netweb 2 years ago.

Download all attachments as: .zip

Change History (4)

#1 @netweb
2 years ago

  • Description modified (diff)
  • Summary changed from Switch Travis CI environment to Trusty - PHP 5.2 to be no longer available Sept 2017 to Switch Travis CI environment to Trusty - PHP 5.2 & 5.3 no longer available Sept 2017

@netweb
2 years ago

#2 @netweb
2 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 6624:

Build Tools: Switch to Ubuntu Trusty as the the default linux distro for Travis CI.

  • This changeset also explicitly adds dist: precise to the PHP 5.2 and 5.3 build jobs.
  • Travis CI will discontinue support of PHP 5.2 & 5.3 in September 2017 and a further follow up will be required.

Fixes #3127.

#3 @netweb
2 years ago

In 6625:

Build Tools: Move PHP 5.2 and 5.3 Travis CI jobs from the php section to the matrix section.

This changeset is a follow up to [6624] where the "build matrix" was broken, my bad.

See #3127.

Note: See TracTickets for help on using tickets.