Skip to:
Content

Opened 2 years ago

Closed 2 years ago

#3072 closed defect (duplicate)

Error After Upgrade to PHP 7.1 - Missing Initializers

Reported by: blankdistrict Owned by:
Milestone: Priority: high
Severity: critical Version: 2.5.12
Component: General Keywords: needs-patch
Cc:

Description

Compatibility with PHP 7.1 can easily be fixed by adding a couple of initializers in /includes/forums/functions.php

Add initializer to line 1800:

$post_stati = array();

And line 1855:

$meta_query = array();

Based on: https://bbpress.trac.wordpress.org/ticket/3031

Change History (1)

#1 @johnjamesjacoby
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the report. This is fixed for 2.6, and is a duplicate of #3031.

Appreciate you taking the time to create this ticket though!

Note: See TracTickets for help on using tickets.