Skip to:
Content

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3028 closed defect (fixed)

Menu items go missing in 4.7

Reported by: Clorith Owned by:
Milestone: 2.5.12 Priority: high
Severity: major Version: 2.5.11
Component: API - Roles/Capabilities Keywords:
Cc:

Description

The menu items for Forums, Topics and Replies are no longer accessible under wp-admin in 4.7, it might appear that capabilities are not applied to user accounts in the right way when in the back-end.

See report by @andreasneuber at https://wordpress.org/support/topic/when-updating-wp-4-6-1-to-wp-4-7-rc1-39355-then-bbpress-admin-menus-disappear/

Change History (8)

#1 @casiepa
2 years ago

Hi @Clorith, if they are NO other plugins installed on that install, then it might be linked capabilities.

So far I have gathered a checklist and in most of the cases people mentioned to get it back (but that's BEFORE 4.7). See e.g. https://bbpress.org/forums/topic/forums-missing-from-admin/ where it was due to a plugin, but before that it worked for others after the 2nd or 3rd point.

Pascal.

#2 @Clorith
2 years ago

My test site was clean with no other plugins (until I added the capability one to confirm if anything was missing), the items are also there in 4.6.1, but as soon as you upgrade to 4.7 they disappear, this indicates that something is being done the wrong way in core in my opinion (I'd say perhaps in WP core, but given that any other plugin with post types like this work as intended where they don't use a custom capabilities API, I'm leaning more towards it being bbPress specific).

This ticket was mentioned in Slack in #forums by clorith. View the logs.


2 years ago

This ticket was mentioned in Slack in #bbpress by netweb. View the logs.


2 years ago

#5 @johnjamesjacoby
2 years ago

In 6147:

Roles: Port bbp_roles_init() from trunk to 2.5 branch. See: #3028.

#6 @johnjamesjacoby
2 years ago

  • Component changed from General to API - Roles/Capabilities
  • Milestone changed from Awaiting Review to 2.5.12
  • Resolution set to fixed
  • Status changed from new to closed

Sorry for the trouble.

2.5.12 is being released shortly with this fix.

This ticket was mentioned in Slack in #bbpress by boone. View the logs.


2 years ago

#8 @netweb
2 years ago

See also https://bbpress.trac.wordpress.org/changeset/6147

Roles: Port bbp_roles_init() from trunk to 2.5 branch.

Note: See TracTickets for help on using tickets.