Skip to:
Content

Opened 2 years ago

Closed 2 years ago

#3024 closed defect (duplicate)

Notice: bbp_setup_current_user was called incorrectly

Reported by: chj1axr0 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.3
Component: Component - Users Keywords:
Cc:

Description

Fresh install of WordPress 4.8-alpha-39357 with Twenty Seventeen and bbPress 2.6 alpha

Notice:  bbp_setup_current_user was called incorrectly. The current user is being initialized without using $wp->init().
===
Trace:
#6 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(92): wp_get_current_user()
#7 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(917): get_user_locale()
#8 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(879): _get_path_to_translation_from_lang_dir('bbpress')
#9 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(849): _get_path_to_translation('bbpress')
#10 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(947): _load_textdomain_just_in_time('bbpress')
#11 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(122): get_translations_for_domain('bbpress')
#12 /sites/demo.chj1axr0.dev/public/wp-includes/l10n.php(202): translate('bbPress Default', 'bbpress')
#13 /sites/demo.chj1axr0.dev/public/wp-content/plugins/bbpress/bbpress.php(422): __('bbPress Default', 'bbpress')
#14 /sites/demo.chj1axr0.dev/public/wp-includes/class-wp-hook.php(298): bbPress->registe in /sites/demo.chj1axr0.dev/public/wp-includes/functions.php on line 4091

Change History (1)

#1 @netweb
2 years ago

  • Milestone Awaiting Review deleted
  • Priority changed from high to normal
  • Resolution set to duplicate
  • Severity changed from critical to normal
  • Status changed from new to closed
  • Version changed from trunk to 2.3

Thanks for the ticket @chj1axr0, I'm closing this as a duplicate of #2309

The issue was also fixed in #2309, the current bbPress 2.6-alpha via https://bbpress.org/download/ doesn't include this fix just yet, we have a couple of more fixes to add before shipping the next bbPress 2.6 test release.

Note: See TracTickets for help on using tickets.