Skip to:
Content

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#3019 closed defect (duplicate)

translation of "reply" needs context

Reported by: fiskhandlarn Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.10
Component: Locale - i18n/l10n Keywords:
Cc:

Description

bbp_get_reply_to_link() and bbp_get_topic_reply_link() uses "Reply" as a verb (i.e. to reply), whereas bbp_dashboard_widget_right_now() uses "Reply" as nouns (i.e. nr of replies).

The swedish translation for "reply" is different for the verb ("svara") and nouns ("svar"). The current translation (bbpress-sv_SE.po) uses the noun form, thus outputting the edit/reply links with incorrect text.

bbp_get_reply_to_link() and bbp_get_topic_reply_link() could perhaps use _x() instead of __() so that "Reply" can be translated differently?

Change History (3)

#1 @netweb
2 years ago

  • Component changed from General to Locale - i18n/l10n
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the ticket @fiskhandlarn, marking this as a duplicate of #2977, these fixes will ship with bbPress 2.6

You can see these strings in the /dev translation project with context here:
https://translate.wordpress.org/projects/wp-plugins/bbpress/dev/sv/default?filters%5Bterm%5D=reply&filters%5Buser_login%5D=&filters%5Bstatus%5D=current_or_waiting_or_fuzzy_or_untranslated&filters%5Bwith_context%5D=yes&filter=Filter&sort%5Bby%5D=original&sort%5Bhow%5D=desc

#2 @fiskhandlarn
2 years ago

Thank you! (Sorry about posting a duplicate issue, I tried searching beforehand but couldn't find anything X) )

#3 @netweb
2 years ago

No problem @fiskhandlarn, Trac is not the greatest UI/UX in the world, we'd rather have a duplicate ticket than no ticket at all :)

Note: See TracTickets for help on using tickets.