Skip to:
Content

bbPress.org

Opened 3 years ago

Closed 2 years ago

#2992 closed defect (duplicate)

BP activity items not being deleted/edited

Reported by: boonebgorges Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.4
Component: Extend - BuddyPress Keywords:
Cc:

Description

When a topic or reply is edited or deleted, bbPress attempts to update or delete the corresponding BP activity item as appropriate.

However, the attempt is failing because of an error in BBP_BuddyPress_Activity::get_activity_id(). This method verifies the existence of the activity ID corresponding to the post by calling bp_activity_get_specific() - which is good! - but then it checks $existing['total'] to see if it was successful - which is bad! Since BP 2.1, activity queries do not do query for a 'total' count by default; see https://buddypress.trac.wordpress.org/ticket/5629 for background.

Attachments (1)

2992.diff (706 bytes) - added by boonebgorges 3 years ago.

Download all attachments as: .zip

Change History (6)

@boonebgorges
3 years ago

#1 @boonebgorges
3 years ago

Since the 'total' value doesn't seem to be important, I suggest you don't bother with it. See 2992.diff

#2 @r-a-y
3 years ago

#2690 should fix this issue (r5857), but it is only applied to trunk.

I would suggest the fix there to be applied to 2.5-branch as well. (It's also a little cleaner!)

Last edited 3 years ago by r-a-y (previous) (diff)

#3 @boonebgorges
3 years ago

Whoops, my Google-fu failed me when searching for existing tickets. Thanks, @r-a-y !

#4 @danbp
3 years ago

Tested the patch on single & MS installs, with standalone and group forums. Worked like a charm !

Thank you for this.

#5 @thebrandonallen
2 years ago

  • Milestone 2.5.9 deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to 2.5.4

Closing as a duplicate of #2690, since 2.6 is imminent. Version set to 2.5.4, as that was the current version when BP 2.1 was released.

Note: See TracTickets for help on using tickets.