Skip to:
Content

bbPress.org

Opened 3 years ago

Closed 3 years ago

#2953 closed defect (fixed)

Enable phpunit to be run with codecoverage

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Tools - Build Keywords:
Cc:

Description

Via #WP36867

phpunit --coverage-clover=clover.xml will fail if PHP files for coverage are not whitelisted as PHPUnit 5.0 makes the use of a whitelist for code coverage mandatory.

See https://github.com/sebastianbergmann/phpunit-documentation/issues/335

Though this is not yet implemented it will be included in the https://github.com/bbpress/bbPress repo soon

Attachments (1)

2953.diff (383 bytes) - added by netweb 3 years ago.

Download all attachments as: .zip

Change History (2)

@netweb
3 years ago

#1 @netweb
3 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 6025:

Build Tools: Set a whitelist for PHPUnit code coverage

This chageset adds a PHPUnit whitelist of files for use with code coverage tests analsyis tools.

Hat tip jorbin.
Fixes #2953.

Note: See TracTickets for help on using tickets.