Skip to:
Content

Opened 3 years ago

Closed 3 years ago

#2920 closed defect (fixed)

Use NodeJS LTS 4.x.x as the minimum supported NodeJS version

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: Tools - Build Keywords:
Cc:

Description

Via #WP35105 Specify minimum node and npm version in package.json

WordPress will also be bumping to the 4.2.x LTS branch of NodeJS (ref)

This ticket adds NodeJS version 4.2.1 as the minimum supported NodeJS version per the initial 4.2.x LTS branch release announcement here, see also https://github.com/nodejs/LTS/blob/master/README.md

https://raw.githubusercontent.com/nodejs/LTS/master/schedule.png

Attachments (2)

2920.diff (330 bytes) - added by netweb 3 years ago.
2920.2.diff (729 bytes) - added by netweb 3 years ago.
Include NodeJS TRAVIS_NODE_VERSION Travis CI env variable

Download all attachments as: .zip

Change History (6)

@netweb
3 years ago

@netweb
3 years ago

Include NodeJS TRAVIS_NODE_VERSION Travis CI env variable

#1 @netweb
3 years ago

In 5984:

Build Tools: Add minimum NodeJS 4.2.x LTS version

This changeset sets the minimum required NodeJS version supported. This is required as various NPM modules now require a minimum version greater than the default v0.10.x currently in use.

See #2920.

#2 @netweb
3 years ago

In 5985:

Build Tools: Define TRAVIS_NODE_VERSION as a global variable for Travis CI

See #2920

#3 @netweb
3 years ago

In 5986:

Build Tools: Install NodeJS 4.x.x using NVM in Travis CI

See #2920

#4 @netweb
3 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5987:

Build Tools: Revert Travis CI TRAVIS_NODE_VERSION environment variable changes from r5984/r5985, installing NodeJS 4.x.x via NVM is sufficient per r5986.

Fixes #2920.

Note: See TracTickets for help on using tickets.