Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#2918 closed defect (fixed)

Update various NodeJS dependencies

Reported by: netweb Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version:
Component: Tools - Build Keywords:
Cc:

Description

Various NodeJS dependencies need updating:

 grunt-check-dependencies  ~0.11.2  →  ~0.12.0 
 grunt-contrib-clean        ~0.6.0  →   ~1.0.0 
 grunt-contrib-copy         ~0.8.0  →   ~1.0.0 
 grunt-contrib-cssmin      ~0.13.0  →   ~1.0.0 
 grunt-contrib-jshint      ~0.11.2  →   ~1.0.0 
 grunt-contrib-uglify       ~0.9.2  →   ~1.0.0 
 grunt-rtlcss               ~1.6.0  →   ~2.0.1 
 grunt-sass                 ~1.0.0  →   ~1.1.0 
 matchdep                   ~0.3.0  →   ~1.0.1 

Change History (15)

#1 @netweb
3 years ago

In 5973:

Build Tools: Update grunt-contrib-cssmin from 0.13.0 to 1.0.0

See #2918

#2 @netweb
3 years ago

In 5974:

Build Tools: Update grunt-contrib-cssmin from 0.6.0 to 1.0.0

See #2918

#3 @netweb
3 years ago

In 5975:

Build Tools: Update grunt-contrib-copy from 0.8.0 to 1.0.0

See #2918

#4 @netweb
3 years ago

In 5976:

Build Tools: Update grunt-contrib-copy from 0.8.0 to 1.0.0

This changeset fixes the "my bad" r5975 commit where the version was accidentally committed as 0.1.0 instead of 1.0.0

See #2918

#5 @netweb
3 years ago

In 5977:

Build Tools: Update grunt-contrib-jshint from 0.11.2 to 1.0.0

See #2918

#6 @netweb
3 years ago

In 5978:

Build Tools: Update grunt-contrib-uglify from 0.9.2 to 1.0.0

See #2918

#7 @netweb
3 years ago

In 5979:

Build Tools: Update grunt-check-dependencies from 0.11.2 to 0.12.0

See #2918

#8 @netweb
3 years ago

In 5980:

Build Tools: Update matchdep from 0.3.0 to 1.0.1

See #2918

#9 @netweb
3 years ago

In 5981:

Build Tools: Update grunt-sass from 1.0.0 to 1.1.0

See #2918

#10 @netweb
3 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5982:

Build Tools: Update grunt-rtlcss from 1.6.0 to 2.0.1

Fixes #2918

#11 @netweb
3 years ago

In 5983:

Build Tools: Renamed grunt-rtlcss option options.config to RTLCSS v2.x options.opts option

See #2918

#12 @netweb
3 years ago

In 5992:

Build Tools: Update grunt-contrib-watch from 0.6.1 to 1.0.0

See #2918

#13 @netweb
3 years ago

In 5999:

Build Tools: Update grunt-legacy-util from 0.2.0 to 1.0.0

See also: https://github.com/gruntjs/grunt-legacy-util/compare/v0.2.0...v1.0.0

See #2918

#14 @netweb
3 years ago

In 6000:

Build Tools: Revert [5999] grunt-legacy-util update, from 0.2.0 to 1.0.0

This changeset reverts the above change as I missed the 1.0.0 recommended change to use require('child_process').spawn over grunt.util.spawn. Per NodeJS docs here and here for NodeJS versions 5.x and 4.x respectively this needs some more testing and changes to the Grunt phpunit task and multi task.

Another option per grunt-legacy-util #10 is to switch to cross-spawn-async

Both above options will require *nix and Windows testing.

6000 is the natural number following 5999 and preceding 6001.

See #2918

This ticket was mentioned in Slack in #meta by netweb. View the logs.


2 years ago

Note: See TracTickets for help on using tickets.