Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2892 closed defect (duplicate)

Notice: bbp_setup_current_user was called incorrectly (seen in Customizer)

Reported by: slaFFik Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Tools - Warnings/Notices Keywords:
Cc:

Description

Notice: bbp_setup_current_user was called <strong>incorrectly</strong>. The current user is being initialized without using $wp->init(). Please see <a href="https://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 2.3.) in W:\OpenServer\domains\bp\trunk\wp-includes\functions.php on line 

Using trunk BuddyPress and WordPress 4.4-beta2-35481 also (in case it matters)

Change History (4)

#1 @netweb
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

@slaFFik I'm going to close this as a duplicate of #2309

Specifically the customizer fix for this was in [5618] so if your using bbPress trunk you shouldn't be seeing this.

See also http://codex.bbpress.org/bbp_setup_current_user/was-called-incorrectly/

#2 follow-up: @slaFFik
3 years ago

I was using the latest stable bbPress (writing just for the sake of completeness). And BuddyPress.

#3 in reply to: ↑ 2 @netweb
3 years ago

Replying to slaFFik:

I was using the latest stable bbPress (writing just for the sake of completeness). And BuddyPress.

Right, thanks for the follow up, latest stable is 2.5.8 and indeed this is currently an issue for 2.5.8 and fixed for 2.6.

This ticket was mentioned in Slack in #bbpress by tharsheblows. View the logs.


3 years ago

Note: See TracTickets for help on using tickets.