Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 4 weeks ago

#2889 closed defect (fixed)

Function bbp_make_clickable() problem with shortcodes

Reported by: GDragoN Owned by:
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: API - Formatting Keywords:
Cc:

Description

When URL is inside the shortcode, in some cases it will break the shortcode processing and whole content. This is caused by bbp_make_clickable() function that fails to properly process URL.

This is OK:

[shortcode]https://www.dev4press.com/ [/shortcode]

And this is OK:

[shortcode]https://www.dev4press.com[/shortcode]

But, this is not OK:

[shortcode]https://www.dev4press.com/[/shortcode]

When the URL ends with / character and shortcode is closed immediately after, bbp_make_clickable() will include shortcode ending in URL and break the layout later when shortcode parser takes over.

Milan

Change History (6)

#1 @netweb
3 years ago

Milan,

I've tried replicating this with a few shotcodes here on my test site but cannot reproduce the issue with bbPress 2.5.8

What shortcode are you using where this happens? Could you maybe add some code here for that shortcut please?

#2 @netweb
3 years ago

  • Priority changed from highest to normal
  • Severity changed from major to normal

#3 @netweb
3 years ago

  • Keywords close added

@GDragoN Could you test this against /trunk now, the changes in [6014] may also have fixed this issue of yours.

#4 @GDragoN
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

It works now. Thanks!

#5 @thebrandonallen
3 years ago

  • Keywords reporter-feedback needs-patch close removed
  • Milestone changed from Awaiting Review to 2.6

#6 @johnjamesjacoby
4 weeks ago

Assigning all closed & unassigned tickets in the 2.6 milestone to myself.

Note: See TracTickets for help on using tickets.