Skip to:
Content

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#2867 closed defect (worksforme)

post becomes invisible

Reported by: freakyy85 Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.8
Component: General Keywords:
Cc:

Description

Hi. IF i create a new forum post, set it as closed, and then enable it again it becomes invisible means, if i click on the post it doesnt have any content anymore.

Change History (9)

#1 @freakyy85
3 years ago

its also sticky.

#2 @freakyy85
3 years ago

I also get an internal server error when trying to set a post closed using the link over the post itself.

[Thu Sep 24 16:16:26 2015] [warn] [client 79.210.55.100] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.gw2-togo.de/forums/forum/oeffentliche-diskussion/
[Thu Sep 24 16:16:26 2015] [error] [client 79.210.55.100] Premature end of script headers: index.php, referer: http://www.gw2-togo.de/forums/forum/oeffentliche-diskussion/
[Thu Sep 24 16:21:30 2015] [warn] [client 79.210.55.100] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.gw2-togo.de/forums/topic/willkommen-im-forum/
[Thu Sep 24 16:21:30 2015] [error] [client 79.210.55.100] Premature end of script headers: index.php, referer: http://www.gw2-togo.de/forums/topic/willkommen-im-forum/

#3 @freakyy85
3 years ago

[Thu Sep 24 16:26:58 2015] [warn] [client 79.210.55.100] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.gw2-togo.de/forums/topic/willkommen-im-forum/
[Thu Sep 24 16:26:58 2015] [warn] [client 79.210.55.100] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function, referer: http://www.gw2-togo.de/forums/topic/willkommen-im-forum/

If I post something. I don't know where the error is?

#4 @thebrandonallen
3 years ago

  • Keywords reporter-feedback added

This appears to be an issue with your server configuration. Do the timestamps of the errors you posted correspond with when you tried to close/re-open a forum post?

#5 @freakyy85
3 years ago

  • Keywords reporter-feedback removed
  • Version set to 2.5.8

no didn't im trying on a new installation. it still doesn't work. the error log shows nothing.
please can you help me i'd really like to use sticky posts and bbpress ;)

#6 @freakyy85
3 years ago

the post disappears on the page. then under topics int he admin menu, it shows the post as draft.

#7 @thebrandonallen
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can you post this in the bbPress support forums? Trac really isn't the place for troubleshooting. I'll watch for your post.

#8 @Robkk
3 years ago

I am getting this bug too when I tested with no other plugins, but the latest bbPress 2.5.8 and while testing with the default themes twenty thirteen, fourteen, and fifteen.

While creating a topic from the frontend or backend set the topic status as closed, then publish the topic, then decide to later reopen it, it sets the topic as a draft.

While testing with 2.6, this issue does not seem to be present.


Last edited 3 years ago by Robkk (previous) (diff)

#9 @netweb
3 years ago

Related: #2630 Closing a private topic changes status back to public

Via the backend with bbPress 2.5.8:

  1. Create a new topic with status closed
  • Result: Backend topic status is open
  • Expected: Backend topic status is closed

Via the frontend with bbPress 2.5.8

  1. Create a topic with with status closed
  2. Reopen the topic
  • Result: Topic status is draft

Via the backend with bbPress 2.6 r5952:

  1. Create a new topic with status closed
  • Result: Backend topic status is open
  • Expected: Backend topic status is closed

Via the backend with bbPress 2.5.8:

  1. Create a new topic with status closed
  • Result: Backend topic status is open
  • Expected: Backend topic status is closed

Via the frontend with bbPress 2.6 r5952:

  1. Create a topic with with status closed
  2. Reopen the topic
  • Result: Topic status is open
  • Expected result: Topic status is open

The backend status issues are the same as what is detailed in #2630 (albeit a slightly different use case)

The frontend status issues were fixed in #2653

As such I'm going to mark this as a duplicate of #2653 and the backend status will be address in #2630

Note: See TracTickets for help on using tickets.