Skip to:
Content

bbPress.org

Opened 5 years ago

Closed 2 years ago

Last modified 2 years ago

#2752 closed defect (duplicate)

bbpress private forums showing up in activity

Reported by: milenushka Owned by: milenushka
Milestone: Priority: normal
Severity: normal Version: 2.5.4
Component: Extend - BuddyPress Keywords:
Cc:

Description

This is a follow-up to #2327.

Hello moderators. I have found this issue recently and have read all the threads I could find, with no success of solving it.

https://buddypress.org/support/topic/private-group-posts-appearing-in-activity-stream-to-non-members/

https://buddypress.org/support/topic/private-group-topics-appearing-in-activity-stream-help/

https://buddypress.org/support/topic/bugs-between-bbpress-and-buddypress/

https://bbpress.trac.wordpress.org/ticket/2327

My PRIVATE group’s forum topics and replies show up in the activity stream.

bbpress 2.5.4
buddypress 2.1.1
wp 4.0.1

action taken:
1.turned off all the plugins but buddypress and bbpress

  1. tested with another theme
  2. also used the Tools > Forums to recaculate and resync the forums

the problem remains.

Please help.

p.s the previous ticket was closed 15 months ago, but i found people describingg this issue from 6 months ago. so clearly it remains unsolved. see the last reply here

https://buddypress.org/support/topic/private-group-posts-appearing-in-activity-stream-to-non-members/

thankx

Change History (6)

#1 @milenushka
5 years ago

  • Owner set to milenushka

Hi, I have more info now.

I can confirm that this is what is happening:

If a group is created as private and a forum is created with it- it will be a private forum and its activity will remain invisible to non group members.

If a private group is created and an existed forum is added to it- this forum need to be changed to private- otherwise the forum will remain public, even though the group attached to it is private- and the activity of the forum will be public.

Same goes for a public group+ forum , that is created together and later group setting are set to private. Forum remains public- forum’s activity -too.

Is there something to be done with the buddypress-bbpress integration to make this work?
Creating a function that will make a forum private too- if the group it was attached to becomes private?

My thread in buddypress forums
https://buddypress.org/support/topic/forum-in-private-groups/

another person who found this
https://buddypress.org/support/topic/forum-in-private-groups/

thank you

#2 @netweb
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate: #2599

@milenushka, thanks for the ticket, see the above ticket for a workaround :)

#3 @netweb
5 years ago

  • Priority changed from high to normal
  • Severity changed from critical to normal

#4 @cjerrells
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hi,

I am having this issue.

WordPress 4.7.4
BuddyPress 2.8.2
bbPress 2.5.12

Group is set as private.
The group's Forum is set as public.

The forum is (correctly) not accessible to non-members of the group. However new discussions and replies generate BuddyPress activity items which are visible to all users of the site including non-members.

I have tried:

  • Setting the forum as private too - but then it didn't even show up in the group. I got "This group does not currently have a forum." on the Forum tab of the group's page.
  • Using the Repair tools "Recalculate private and hidden forums" and "Repair BuddyPress Group Forum relationships".
  • Removing the forum from the Group and adding it back again.
  • Setting the Group as Public and then back to Private again (since it seemed like that might trigger the fix from #2599 )

None of these solved it.

I'm happy to do whatever I can to help diagnose this further, but I'm not really sure what else to try at this point.

I was told on BuddyPress ticket 6198 that this is a bbPress issue. The comments above seem to suggest #2599 fixed it, but it doesn't seem to have. The group and forum visibility both seem to be set correctly, but activity items from the private group are still visible to all.

#5 @netweb
2 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

This issue is a duplicate of #2599, anything relating to that issue should be discussed on that ticket, not this ticket please.

Also as you are using bbPress 2.5.12 the fix hasn't shipped for the 2.5.x branch, the fix will ship in the next release of bbPress, bbPress 2.6.

If you'd like to test bbPress 2.6 then read the following post on our forums :)

https://bbpress.org/forums/topic/bbpress-2-6-beta/

#6 @cjerrells
2 years ago

Oh! It's surprising that a privacy-related bugfix from 21 months ago hasn't made it into the latest official version.

Thank you for your helpful reply. Unfortunately I'm talking about a live site, and it seems the advice is to not upgrade to 2.6 beta on a live site so that isn't an option.

I posted on this ticket rather than #2599 because the issue description here was much closer to what I'm experiencing - and since the fix there didn't seem to have fixed it for me I thought it might be a separate issue after all.

If the fix isn't part of 2.5 then I guess I'll have to manually apply the patch and see if that does fix it. Thanks!

Note: See TracTickets for help on using tickets.