Skip to:
Content

bbPress.org

Opened 5 years ago

Closed 3 years ago

#2743 closed defect (invalid)

User pages still act like 404 error.

Reported by: deltafactory Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.5.4
Component: Component - Users Keywords:
Cc:

Description

Possible regression for #1478?

In short, WP::handle_404() still fires because none of the criteria are met. It fires after bbp_parse_query() which gives ample time to meet some of the criteria. What would work without seeming like a workaround?

Would a patch to WP core to override WP::handle_404() via filter be appropriate?

This error won't occur when viewing your own profile.

Change History (2)

This ticket was mentioned in Slack in #bbpress by deltafactory. View the logs.


5 years ago

#2 @thebrandonallen
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I can't reproduce this on trunk (future 2.6). If this is still an issue, please reopen with more details on how to reproduce this issue.

Note: See TracTickets for help on using tickets.