Skip to:
Content

bbPress.org

Opened 5 years ago

Closed 4 years ago

#2740 closed defect (fixed)

Custom forum visibilities have no save action

Reported by: johnjamesjacoby Owned by: johnjamesjacoby
Milestone: 2.6 Priority: normal
Severity: normal Version: 2.1
Component: Component - Forums Keywords: has-patch
Cc:

Description

While it's possible to filter the available forum visibilities in the dropdown list, the save routine is hardcoded in bbp_save_forum_extras

Attachments (1)

2740.patch (3.3 KB) - added by johnjamesjacoby 5 years ago.

Download all attachments as: .zip

Change History (4)

#1 @johnjamesjacoby
5 years ago

2740.patch does a few things:

  • Removes the switch statement in lieu of an action
  • Introduces a helper function to add default visibility save actions
  • Adds separators in Forum Actions section

This is a bit of a hack until we build out a BBP_Forum_Visibility class to contain the properties and routines of each one. Until then, it's a good stop-gap to get them working as intended.

This ticket was mentioned in Slack in #bbpress by jjj. View the logs.


5 years ago

#3 @johnjamesjacoby
4 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 5856:

Forums: Introduce bbp_update_forum_visibility action in bbp_save_forum_extras()

This changeset provides custom visibilites with an execution point to perform their own actions.

Fixes #2740.

Note: See TracTickets for help on using tickets.