Skip to:
Content

Opened 5 years ago

Closed 4 years ago

#2595 closed defect (fixed)

Invalid markup on BP group topic 404 page

Reported by: boonebgorges Owned by: johnjamesjacoby
Milestone: 2.6 Priority: normal
Severity: normal Version: trunk
Component: Extend - BuddyPress Keywords: has-patch
Cc:

Description

When viewing http://example.com/groups/groupname/forum/topic/foo, and no topic by the name 'foo' exists, the HTML renderer is bailing without closing the 'bbpress-forums' div. The result is invalid markup that messes with some themes. Here's where the tag is opened: https://bbpress.trac.wordpress.org/browser/tags/2.5.3/includes/extend/buddypress/groups.php#L742 and here is where it should be closed but is not: https://bbpress.trac.wordpress.org/browser/tags/2.5.3/includes/extend/buddypress/groups.php#L792

Patch attached.

Attachments (2)

2595.patch (592 bytes) - added by boonebgorges 5 years ago.
2595.2.patch (1.1 KB) - added by netweb 5 years ago.

Download all attachments as: .zip

Change History (5)

@boonebgorges
5 years ago

@netweb
5 years ago

#1 @netweb
5 years ago

  • Keywords has-patch added
  • Milestone set to 2.6

Thanks Boone, patch 2595.2.patch adds the same same closing div for 'single reply'

This ticket was mentioned in IRC in #bbpress-dev by netweb. View the logs.


5 years ago

#3 @johnjamesjacoby
4 years ago

  • Owner set to johnjamesjacoby
  • Resolution set to fixed
  • Status changed from new to closed

In 5511:

In our BuddyPress Groups display_forums method, break out of switch statement rather than return. This prevents malformed markup caused by not allowing the method to continue on. Hat-tip boonebgorges, netweb. Fixes #2595.

Note: See TracTickets for help on using tickets.