Skip to:
Content

Opened 5 years ago

Closed 4 years ago

#2594 closed defect (fixed)

BuddyPress favorites and/or subscription menus still visible when components are disabled

Reported by: mpa4hu Owned by: netweb
Milestone: 2.6 Priority: normal
Severity: normal Version: 2.5.3
Component: Extend - BuddyPress Keywords: has-patch
Cc: jjjay@…

Description

to reproduce this
Go to forum settings and disable Allow users to subscribe to forums and topics
Then go to profile page (buddypress) and then forums.

Here "Subscriptions" menu is still visible but will display white screen.
Can anybody confirm this?

Attachments (1)

2594.diff (1.3 KB) - added by tharsheblows 4 years ago.
check that subs and faves are active before including in bp profiles

Download all attachments as: .zip

Change History (6)

#1 @mpa4hu
5 years ago

Edit - this will only happen for your own profile, viewing others profile wont display this.

But is this intended behavior? I just don't see a reason to display menu for disabled functionality.

#2 @netweb
5 years ago

  • Component changed from General to BuddyPress
  • Milestone changed from Awaiting Review to 2.6
  • Summary changed from Menu is still visible when subscription are disabled to BuddyPress favorites and/or subscription menus still visible when components are disabled
  • Version set to 2.5.3

Confirmed for 'favorites' and 'subscriptions'

  • Menu items should check bbp_is_favorites_active and bbp_is_subscriptions_active before displaying bbPress' favorites and/or subscriptions menu items in BuddyPress member profiles.

@tharsheblows
4 years ago

check that subs and faves are active before including in bp profiles

#3 @tharsheblows
4 years ago

  • Cc jjjay@… added

#4 @tharsheblows
4 years ago

  • Keywords has-patch added

#5 @netweb
4 years ago

  • Owner set to netweb
  • Resolution set to fixed
  • Status changed from new to closed

In 5653:

BuddyPress: Use bbp_is_favorites_active() and bbp_is_subscriptions_active() respectively to check if bbPress' favorites and/or subscriptions are enabled before displaying menu items in BuddyPress member profiles.

Props tharsheblows. Fixes #2594

Note: See TracTickets for help on using tickets.